Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

So, say I share my system (C) drive through windows (E.g. properties -> Sharing -> Advanced Sharing -> Share this Folder). I can then access this drive at \\Comp\C on another networked computer - all is well.

However, if I insert a removable (USB) disk, say "E", and proceed to share it the same way, when I attempt to access \\Comp\E (either directly or through browsing) I get an error:

Windows cannot access \\Comp\E

You do not have permission to access \\Comp\E. Contact your network administrator to request access.

Now, the permissions (Advanced Sharing -> Permissions) are set with "Everyone" having read access (same as the internal drive), so this doesn't make a lot of sense.

Also of note, I have an SSH server on my computer (through Cygwin) and even through SSH (logging in as an administrator user) I cannot access /cygdrive/e (although /cygdrive/c is accessible).

As a final note, the drive is of course accessible on the host machine (E:\), and also at \\Comp\E on the host machine.

share|improve this question
    
Also - I have UAC disabled if that makes any difference. –  connec Nov 3 '10 at 19:43
    
Also - Creating a symlink to /cygdrive/e from another location is also innaccessible (ssh). –  connec Nov 3 '10 at 19:46

3 Answers 3

A few things you can check:

Run the Local Security Policy, Local Policies, Security Options (secpol.msc): these settings have explanations, so I wont provide a lot of details.

  1. Devices: Restrict CD-ROM access to locally logged-on user only
  2. Network access: Let Everyone permissions apply to anonymous users

You can also use the Auditing Policy and enable failed access auditing to log (to the Audit Event Log) access requests and that might give you a clue as well.

And last, but not least, don't forget to double check the permissions on the share itself (Permissions button on the Advanced Sharing dialog).

Hope that helps!

share|improve this answer
    
Well I checked both of those settings, and changed them to disabled/enabled, restarted and still no joy. I also added "ANONYMOUS LOGON" with full control to the permissions (just in case) which also did not work. –  connec Nov 3 '10 at 21:45
    
What file system is the drive formatted with? –  Coding Gorilla Nov 4 '10 at 13:08
    
It is formatted with NTFS. –  connec Nov 5 '10 at 13:29
    
OK, I'm out of ideas. Sorry... –  Coding Gorilla Nov 5 '10 at 14:06
    
If it's NTFS, you should have an Security tab in the drive's properties (different from the sharing permissions) where you should also grant the necessary access to either Users or Guest depending on which credential you use from the other computer. –  billc.cn Oct 7 '11 at 15:01

Double check the permissions. Make sure that the two permission look identical. Sometimes Everyone having read permissions isn't enough (even though it would seem so). Just to make sure that it isn't an issue, give everyone full control. This should work as long as there aren't special groups/people set up with restricted permissions and you are that user.

share|improve this answer
    
Hi David, I tried with "Full Permission" on "Everyone" to no avail. It's possible there's some dodgy group configuration somewhere as I did something non-standard during my SSH setup. How can I check/configure all of my Users/Groups? –  connec Nov 3 '10 at 20:10
    
I am pondering on this (I wanted to let you know that I am going to try to answer you). Give me 24 hours before you suspect that I gave up. Here is what I know as far as my computer networking associates degree has got me. There are two tiers of permissions. You have the notwork permissions, and the folder/file permissions. I believe this is right, I am just trying to jog my memory. I am going to do some research. I believe I have the exact answer in my website at dlusk.com. Go to sitemap and look for the document if you want to help me find it. –  David Nov 3 '10 at 20:42
    
Thanks David, I looked through the documents that looked relevant but found nothing related (as far as I could tell). –  connec Nov 3 '10 at 21:49
    
Well I've tried a lot more stuff, including increasing IRPStackSize, disabling my AV (AVG) disabling SSH, and generally just opening permissions much further than is sensible (full access for anonymous users? sure!) and still having the problem... –  connec Nov 3 '10 at 22:48
    
Additionally I tried accessing it through a 'homegroup', which also failed. –  connec Nov 3 '10 at 23:10

Is E: formatted NTFS? [YES] Is E: an external Seagate drive?

Was reading something that kind of gave me the idea that certain Seagate external HDD's are not "designed" to be shared across a network.

I ran into that problem with W7 & an NTFS formatted Seagate external drive. I subsequently formatted the drive exFAT & was able to access the share across a network. Not sure if it is a Seagate designed limitation that does not apply to exFAT or if it was something I screwed up in setting the share/permissions the first go around when the drive was NTFS formatted?

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.