Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Does anyone know why I can RDP to servers within the domain my PC is logged into, but I cannot RDP to servers in other domains, and how I could fix this problem?

I've recently upgraded from a 5 year old PC running Windows 7 Ultimate to a new PC running Windows 7 Professional x64. The old Windows 7 machine had no problems RDP'ing into servers outside my current domain. When I try with the new machine, however, I get the following error message:

Remote Desktop can't connect to the remote computer for one of these reasons:

1) Remote access to the server is not enabled

2) The remote computer is turned off

3) The remote computer is not available on the network

This message comes up instantly when I click the Connect button on the RDP client. This suggests the RDP client is not even trying to find the IP address I specify (normally if I specify an IP address that doesn't exist the client will try for a minute or so then eventually time out).

For simplicity, I'll call the server I want to RDP to, outside my current domain, the target server.

Even though I cannot RDP to the target server from my PC I can ping it. I can also RDP to another server inside the domain and then RDP from that server to the target server outside the domain.

I'm running CA eTrust anti-virus on my PC and Windows Firewall is turned off. The About screen on the RDP client says Shell Version 6.1.7600, Control version 6.1.7600, Network Level Authentication supported, Remote Desktop Protocol 7.0 supported.

share|improve this question
What happens when you try to RDP to the server using its IP address? – user3463 Nov 3 '10 at 22:53
I use the IP address for these external servers, outside of the domain, when I try to RDP to them. – SimonTewsi Nov 3 '10 at 22:59
up vote 1 down vote accepted

Got to the bottom of it. Microsoft Firewall Client is installed on my PC. Don't know anything about it, although others at work tell me it's not needed for Windows 7 (a Google search seems to suggest it may be useful for Windows 7 in some situations, however). Anyway, the problem was fixed in one of two ways:

  1. Open the Microsoft Firewall Client for ISA Server (I found it via the search box in the Start Menu - typed "Firewall" then selected "Microsoft Firewall Client Management" from the search results). In the Settings tab uncheck "Enable Microsoft Firewall Client for ISA Server" then click OK.

  2. Shutting down the Firewall Client Agent service (via the Services console). To avoid the service starting up again when you next start the machine, change the Startup type from Automatic to Manual.

share|improve this answer

Are you able to ping these other machines? You may want to speak to your domain administrator to see if there are issues with how trusts and policies are configured across domains.

share|improve this answer
Yes, I can ping the external servers, outside of the domain, from my PC. – SimonTewsi Nov 3 '10 at 23:53
One suggestion I saw in another forum was to try Telneting to the external server from a command prompt: >telnet {server IP address} 3389 (ie connect on port 3389). When I tried this from my PC it failed. However, when I tried it from the intermediate server, the one that I can RDP to the external server from, it succeeded. Don't know what to do with this information, though. – SimonTewsi Nov 3 '10 at 23:54
I can telnet to the intermediate server on port 3389 but it fails if I try to telnet to the external server on port 3389 from my PC. I can telnet on 3389 from the intermediate server to the external server ok, though. – SimonTewsi Nov 4 '10 at 1:05

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .