Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have an i7 intel core. Normally it shows 8 cpu's in my task manager, however for some strange reason it does not anymore. I can't recall changing anything. I noticed this problem when I wanted to run parallel matlab code locally on 8 cpu's. It only allowed a max of 1.

However if I go to task manager I can see my 8 different processors. Also when I go to msconfig to boot.ini numproc says 1.

Anyone know what might cause this or how I can fix this?

Thx

Edit: It's windows XP 64bit btw

share|improve this question
    
which version of windows? –  akira Nov 4 '10 at 11:26
1  
You write: Normally it shows 8 cpu's in my task manager, however for some strange reason it does not anymore. And later: However if I go to task manager I can see my 8 different processors. I am confused: Can you see those 8 CPUs in the task manager, or not? –  Suma Nov 5 '10 at 9:24
add comment

3 Answers

up vote 3 down vote accepted

enter image description here

  1. Click the Start button.
  2. Type: msconfig
  3. Open it and go to the second tab called Boot.
  4. By clicking "Advanced Options..." you can change the "Number of processors",
    as shown with black arrows in the image above. It is best to just disable it so it auto-detects.
share|improve this answer
    
disabling it did the job, thx!! –  WtFudgE Nov 9 '10 at 14:20
add comment

If it's Windows 7/Vista, Install EasyBCD.

Click on advanced settings, and and uncheck "Limit Windows to x CPUs"

It should be something like:

enter image description here

share|improve this answer
add comment

Check the bios. In mine there is something like a MultiCore Yes/No setting.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.