Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have two network drives mapped (S: and U:). When I first log into Windows their type shows as "Disconnected Network Drive". How can I get them to to connect automatically?

More Info

They connect as soon as I access them in Windows Explorer. The reason that I even noticed is that when I open Dreamweaver or Netbeans IDE, they do not initiate the connection and are unable to see the files in those mapped drives. I have made a habit of opening Windows Explorer and browsing the drives as soon as I log in. It's annoying to have to do that, which led me to post this question.

share|improve this question
    
Are you able to access the drives by double-clicking them (in My Computer) or are they inaccessible? Where I work I frequently encounter the same situation but I have no difficulty accessing the drives. –  Xantec Nov 4 '10 at 14:12
    
Yes, I can access them by clicking them, they are not inaccessible. –  Sonny Nov 4 '10 at 16:38
add comment

2 Answers

up vote 2 down vote accepted

It just means that when the drives were loaded, that it could not access them. This could be because someone is offsite, and not on the VPN, or that the drives are mapped by a system logon script or something, which happens before a user logon. (also a group policy tied to the machine)

It really doesn't make much difference, you can just click on them later and they will update, it just does not poll the drives, as that would really increase network traffic. It looks and sounds bad, but everything should be fine.

share|improve this answer
    
I updated my post. It's not "bad", but creates a minor annoyance. –  Sonny Nov 4 '10 at 16:43
    
@sonny, did you map them manually, and tell them to reconnect at login, or is it done via another way, such as GPO or logon scripts? –  Brian Nov 4 '10 at 17:06
    
I mapped them manually. –  Sonny Nov 4 '10 at 17:09
    
I am going to accept your answer, even though I never solved the problem. –  Sonny Mar 17 '11 at 16:07
add comment

Do you have the Reconnect at logon box checked? It's basically the same as the /persistent:yes flag with net use. Only problem is it can lock up Explorer if the computer can't find the server, so it might be a good thing that it starts as disconnected.

alt text

share|improve this answer
    
Yes, that box was checked when creating the mapped drive. –  Sonny Nov 4 '10 at 16:37
1  
If the computer can't find the server after a matter of time (not sure how long), it'll mark the drive as disconnected. If it doesn't, Explorer will hang trying to find it every time it comes across it. –  churnd Nov 7 '10 at 15:04
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.