Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have one Linksys WRT54GL router running Tomato firmware. Connected to it via ethernet are two computers with Static IP addresses.

The first computer is using the default RDP port 3389. I set up port-forwarding on TCP to that computer's static IP.

On the second computer I changed the RDP port to 3398 at: HKEY_LOCAL_MACHINE > System > CurrentControlSet > Control > TerminalServer > WinStations > RDP-Tcp. Then I set up port-forwarding on TCP once again to that computer's static IP.

Both computers have Remote Connections enabled from Any version the Remote Desktop Client.

From both the same network and an external network I tested remote connections to both computers: Only the first computer connects, the second won't.

I had previously got this working with the same router, and for awhile I had switched to a new N router (Dlink DIR-655) before recently switching back to the Linksys. Since switching back (with no configuration changes) something is going wrong and I can't quite figure out what it is.

Additional things tried:

  • Running ipconfig /release /renew on both computers after switching back to the original router (WRT54GL) to obtain the proper local IP.
  • Clearing arp tables of old N router's IP addresses on both computers, which were set statically to 192.168.0., whereas the WRT54GL is 192.168.1..

Update: I'm also connecting using ip+port (192.168.1.145:3398)

share|improve this question
add comment

2 Answers

up vote 0 down vote accepted

If the computer is running Vista or above, did you also allow port 3398 through the windows firewall?

share|improve this answer
    
Ah ha! between routers I had re-enabled the firewall for something whereas before I had it disabled for testing. I swear of half my problems where I can't connect to something, this is the reason and I never learn! –  Jeff Dalley Nov 4 '10 at 17:16
    
how do actually allow the port through the windows firewall? –  ray247 Feb 25 at 15:43
add comment

When you connect to a computer with a non-standard port, you need to include the port number in the Computer field of the RDP client.

eg.

computername:3398

DOMAIN\computername:3398

alt text

It's a better idea to use a VPN.

share|improve this answer
    
Ah sorry I should have said, I am connecting just like this. –  Jeff Dalley Nov 4 '10 at 16:59
    
@Jeff: If you are using Tomato, you can get builds that have OpenVPN, which would be a better solution anyway. I use the Teddybear mod on my Netgear WNR3500L. –  paradroid Nov 4 '10 at 17:04
    
I'm on the latest Tomato build - I'll have to check and see if I can set that up! Thanks. What client do you use for connection? –  Jeff Dalley Nov 4 '10 at 17:17
    
@Jeff: I use the standard OpenVPN client software. –  paradroid Nov 4 '10 at 17:21
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.