Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

There are some websites which I can access only from office Mac (10.6) and I am trying to access them from home also using Mac (10.6). I have set up a dynamic port forwarding

ssh -D 8888 -N  me@office

and then set Firefox proxy settings to localhost:8888, but I get only empty pages. Do I need to set up something at the office Mac as well to make this tunneling working?

UPDATE: I believe that I am using HTTP proxy

$ grep  Tcp /etc/sshd_config
#AllowTcpForwarding yes
#   AllowTcpForwarding no
share|improve this question
add comment

1 Answer

up vote 1 down vote accepted

If you have a default installation of SSH, you shouldn't need to set up anything on your remote Mac, though check that there isn't a AllowTcpForwarding no line in /etc/sshd_config on the remote Mac (I would imagine there would be an error message if there was, anyway).

What sort of proxy are you telling Firefox to use? You are tell it to use a SOCKS proxy, not an HTTP one?

share|improve this answer
    
I have updated my question. I didn't get you last one. There is only HTTP proxy option. –  Andrei Nov 4 '10 at 18:57
1  
As far as I know, you need to use a SOCKS proxy, because that's what SSH is setting up (see man ssh). If Firefox doesn't offer a SOCKS proxy option (which surprises me), you'll need to use the system proxy settings - they're in System Preferences in the network section. Select your network interface, and click advanced, then go to the proxies tab. –  Scott Nov 4 '10 at 20:21
1  
I've just downloaded the latest version of Firefox (3.6.12) it does offer a SOCKS proxy setting, although it labels it "SOCKS Host". It can be accessed by clicking the "Settings" button in the "Network" tab of the "Advanced" section of the preferences. –  Scott Nov 4 '10 at 20:28
    
thanks for help. I have made HTTP proxy empty and set its port to 0, while SOCKS host is localhost and port 8888. Now it works. –  Andrei Nov 5 '10 at 9:12
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.