Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I mounted a remote file system using sshfs (version 2.8.4)

sshfs -o allow_root ./example

but unmounting it fails

> fusermount -u example
umount: /home/joeuser/example: device is busy.
        (In some cases useful info about processes that use
         the device is found by lsof(8) or fuser(1))

Any ideas as to what might be causing this error and how one might fix it?

share|improve this question
up vote 7 down vote accepted

Some program is using a file in the filesystem you're trying to unmount. It could be a file opened for reading or writing, a current directory, or a few more obscure cases. It could even be due to a directory on the filesystem being a mount point.

To investigate, run lsof +f -- example. It will tell what the process(es) are using the filesystem. Make your own judgement as to whether to make them close files, kill them, or defer the unmount operation.

share|improve this answer
Strangely lsof didn't show a gvfsd-archive process, which was left over from having opened (and closed?) an archive file from a file manager GUI. So, also check ps aux | grep gvfsd-archive. – alexei Dec 26 '15 at 21:08

I think you want a lazy unmount:

sudo umount -l example
share|improve this answer
I think your suggestion is incorrect. According to the manual page lazy umount Detach the filesystem from the filesystem hierarchy now, and cleanup all references to the filesystem *as soon as it is not busy* anymore. So it will not resolve the original issue. Agreed with @Gilles, lsof should help here. – user83293 Sep 24 '13 at 6:50
Actually, this worked for me. lsof could not find any open files but umount -l worked. – gerrit Aug 21 '14 at 14:34
This solution also worked for me! – Dan Sep 1 '14 at 22:46
Experienced the same issue with sshfs, this worked for me too. – Orun Bhuiyan Feb 13 at 0:19

I often see "device busy" with sshfs when I have a terminal window open to a directory on the sshfs share. Exiting the terminal or changing directories to a local share then running fusermount -u solves my problems.

share|improve this answer

Running Ubuntu, man fusermount tells about a -z option, which is documented as “lazy unmount”. It seems to be related, but needs a confirmation, which is given by this other man page: fusermount (, which says “lazy unmount (works even if resource is still busy)”. One must use it with the -u, the -z option alone, will produce an error. I tried the -z option, and can confirm it do the trick, but this precisely too much looks like a trick: what does it do exactly? Make it be unmounted automatically as soon as the directory is not busy any‑more? I don't know, not documented, so unsafe.

So here is another option, more verbose, but safer: tries to unmount until it successes, as many time as needed, in a loop.

echo -n "Unmounting...";
fusermount -u -q "$MOUNT_POINT";

while [ "$OK" != "0" ]
   sleep 1;
   echo -n ".";
   fusermount -u -q "$MOUNT_POINT";


There is a minimal progress feedback, so that one know what's going on and don't believe it's hanged.

This option is acceptable from a shell script; for command line interaction, the use of the -z option is more handy, but one must probably be aware the man page does not document it and there may be doubt about what it exactly do.

share|improve this answer

I just had this problem and could not kill -9 the process reading from the mounted filesystem. kill -9 did not work even after fusermount -zu /mount/point or umount -l /mount/point (which worked). The only thing that worked was pkill -9 sshfs.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .