Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

One of the really nice things in Windows 7 (and Windows Vista) is the way that the search box works on the start menu: that is, open the start menu, type stuff until you get what you need, hit enter...

It's stopped working properly on my principal box.

If I type a file path (for example, c:\data\) it works exactly as you'd expect, listing matching folders.

If I type an application name (for example, Excel), instead of the link to Excel appearing, I get a blank icon and "Programs". Similarly for files I know to have been previously indexed/remembered by the system and indeed anything that isn't a file. The most obvious other "broken" elements are URLs - normally if one types or then hitting Enter will launch the browser. Now I get nothing (hitting Enter has no effect).

I'm at a complete loss here as to where even to begin to look to sort this out (which is scary, because I'm supposed to know what I'm doing).

share|improve this question
up vote 1 down vote accepted

Ok, I found the answer here:

The answer that worked for me was to manually delete a registry key as follows:

  1. Using regedit or equivalent (which can be found in your windows folder - c:\windows by default).
  2. Navigate to the following registry key: HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FolderTypes\{ef87b4cb-f2ce-4785-8658-4ca6c63e38c6}

  3. Right-click on this sub key, and then select Delete.

  4. Close regedit
  5. Reboot the machine.

There is also a link, on the above site, to a Microsoft hotfix - however I haven't tried this.

share|improve this answer
Hmm, I appear to not have a FolderTypes key. – Mooing Duck Apr 25 '14 at 1:11

Probably has something to do with your user profile. You can try and create a new profile or do some heavy cleaning within the regedit on your current profile. Maybe reinstall the Search Indexer? It's not an answer to your question but it might help you in the troubleshooting procedure.

share|improve this answer
That's an interesting thought. I can certainly see that the profile on this box may well be a bit overburdened with cruft. – Murph Nov 5 '10 at 17:12
Search indexer reinstall doesn't work (or at least hasn't worked). A basic clean of the registry hasn't either. There are some other interesting things that appear to be at least a bit broken, but blitzing my profile is, erm, challenging! – Murph Nov 10 '10 at 12:09

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .