Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've searched Google, Bing and locally on serverfault, so pardon my if this is a duplicate. I'd think someone must have asked it before, but I just can't find it.

I have a USB device - specifically an Advantech USB-4750 digital IO Module. Advantech's site provides a 32-bit driver download in the form of an EXE. They claim support for win2k, XP and Vista.

I am trying to get this thing working on Windows 7 Ultimate 64-bit. I run the installer, and it reports success. I plug in the device and it shows up in device manager as an "Other Device", and the details show that it doesn't know what driver to use.

In an attempt to figure it out, I installed the driver on a 32-bit XP system. Of course it shows up and works just fine there. I looked in the Device Manager on XP and found the driver file (ads4750s.sys).

Out of desperation, I copied that file to the Win7 box and then tried to manually browse to the driver for the USB device, but Device Manager still says it can't find a driver for the device, even when I point to that file.

I don't have a Vista machine to test this on (paved them all), but since Advantech claims it works, I have no reason to doubt that. I thought that Win7 was supposed to be able to "just use" Vista drivers.

Is there something I can do to get this hardware working?

share|improve this question

migrated from serverfault.com Nov 5 '10 at 14:48

This question came from our site for professional system and network administrators.

add comment

1 Answer 1

Right click on the installation .EXE, select Properties, select Compatibility, and set it to XP SP3 compatibility mode. Then try it.

Edit: Whoops, just noticed you were trying to install this on a 64 bit OS. Sorry, I believe you are out of luck. 32 bit drivers and a 64 bit OS are a no-go on Windows.

share|improve this answer
    
+1 for the idea. Unfortunately I get the same non-working/non-recognized behavior. –  ctacke Nov 4 '10 at 22:52
    
I had mistakenly assumed that since 32-bit apps work 32-bit drivers would as well. Off to see if the OEM has unpublished 64-bit drivers. –  ctacke Nov 4 '10 at 23:03
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.