Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I open firefox and it loads google, then i try and load any site i tried bing and msn and any other website i might load but they just dont open, I'm using Arch Linux. i pinged bing.com and it returns fine, which means its a firefox issue? but i used the built in web browser i got after installing gnome and it only loads google. Not really sure how to fix, help?

added other browsers no luck in their either but the sites all ping okay which means i can transmit data with them. Tried firefox, chromium and the built in browser.

It's not in work offline even if it was it wouldn't affect other browsers.

share|improve this question
add comment

4 Answers

up vote 0 down vote accepted

This pretty much has to be a firewall issue. If you boot the PC using a LiveCD, say Knoppix, can you browse other sites? If so, the problem is Arch's firewall. If you can't, it is your network firewall.

I'm not familiar with Arch's firewall setup, but the first thing I would try is:

service iptables stop

If that fixes things, the problem is your iptables configuration. (You might want to turn iptables back on at some point, unless you're protected by an external firewall.)

share|improve this answer
    
I have a windows 7 install that runs the net fine but only when i set its network card settings to 10Mbps/Full Duplex –  Arch Angel Nov 6 '10 at 13:38
    
It's an issue with Arch Linux, then. Again, check your iptables configuration as mentioned above. –  CarlF Nov 8 '10 at 13:16
add comment

Google.com is probably cached on your computer. You might be using a proxy by accident. Go to your proxy settings and turn the proxy off. This is probably your issue.

-Good Luck

share|improve this answer
    
no fresh install, google default firefox homepage, no proxy enabled just checked –  Arch Angel Nov 5 '10 at 15:59
add comment

Try loading other sites in a different browser, e.g. Chrome or Lynx or KDE or Epiphany. If you can see the sites with the other browser, it's a Firefox issue. Otherwise it's some kind of weird network issue, likely a firewall. Do the test and then update the question.

One thing to check: is FF set for "work offline"?

share|improve this answer
    
By "built in web browser i got after installing gnome" he probably means Epiphany. –  frabjous Nov 5 '10 at 21:07
    
I suggest trying also a simple HTTP client like wget or curl instead of another web browser, to see if that would work. –  vtest Nov 6 '10 at 10:14
    
frabjous, he edited that language in after I posted. –  CarlF Nov 6 '10 at 13:04
add comment

Most likely your browser is in offline mode. This happens if you manually set your internet connection. From Firefox's File menu-> Uncheck the "Work Offline" mode in case it is on.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.