Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Several of our staff download data from a website as an excel (.xls) file. We are able to open the files in Excel 2007 on Windows XP PCs, but not on Windows 7 PCs.

When Trying to open the file we get the following messages:

Excel found unreadable content in 'filename.xls'. Do you want to recover the contents of this workbook? If you trust the source of this workbook, click Yes.

Clicking on Yes leads to:

Unable to read file.

Followed by:

The workbook cannot be opened or repaired by Microsoft Excel because it is corrupt.

Additional Info:

I tried disabling the anti-virus (Symantec Endpoint Protection), in case it was interfering some how.

share|improve this question

migrated from Nov 5 '10 at 23:00

This question came from our site for system and network administrators.

Have you tried downloading with an alternate browser? Have you tried creating/downloading th exact same document on a problem machine and a good machine and comparing their size/stats/md5sum? Have you tried copying a file downloaded from one of the good machines to a problem machine and opening it? Have you tried downloading on a bad machine and opening on a good machine? – Zoredache Nov 5 '10 at 16:39
@Zoredache - We're tied to using IE for support reasons, though I may try downloading a file via another browser to see if it makes a difference. We have many preexisting files created via XP machines plus files downloaded on the Win-7 PCs and the behavior is consistence i.e. works on XP but not on Win-7, regardless of the origin of the file. – Chris Nov 5 '10 at 17:40

After initially being told "We've never heard of this issue" by the software vendor of the web app, we've now been told "It's a known issue and we'll fix in a future release."

share|improve this answer

I found this thread where this issue is solved for some users Try this: Go to File -> options Then Trust Center -> Trust Center Settings Then Protected view uncheck the 3 options there and re-start Excel to test.

If that doesn't work, try to add the download location to the Trusted Locations section.

share|improve this answer
I didn't mean to dredge up an old question... I didn't even see the dates on it. It just came up on the list of questions. – WinOutreach4 Jan 11 '12 at 20:53

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.