Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a problem with my Acer 3820TG machine running Windows 7 (and dual booting with Ubuntu 10.04).

When I try to boot Windows 7 I see this error:

Windows Boot Manager  

Windows failed to start. A recent hardware or software change might be the cause. To fix the problem:   1. Insert your Windows installation disc and restart your computer.   2. Choose your language settings, and then click "Next."   3. Click "repair your computer." If you don't have this disc, contact your system administrator or computer manufacturer for assistance.   Status: 0xc000000f   Info: The boot selection failed because a required device is inaccessible.

I can't exactly remember what my last actions were on Windows. I already searched this error and applied the proposed solutions, I created a repair USB (because I don't have a CD-ROM nor a Windows 7 CD) such as:

  • Repair operating system - it says it cannot repair it
  • Checking disk (chkdsk D: /f /r) - it checks the disk without a problem or error and it takes a pretty long time (more than a hour). However when I restart, I still have the same error.
  • I didn't create a restore point so I pass this option
  • I don't have a system image
  • I tried to run Windows Recovery (I have a recovery partition) but there are just two options:

    1. Format the operating system but retain user data (copies the files under users to c:\backup folder, but when I searched deeper I found that there are some people who already tried this option and couldn't find their user files under backup directory). Plus, I have unfortunately just one partition D (it is a fault I know) because I use always Ubuntu. So this is not applicable in my situation

    2. Format the entire system (Windows). I keep my valuable data in Windows but not in the user folder. I was reaching them from Windows.

  • I tried to repair Windows boot by:

    bootrec /fixMBR
    bootrec /fixBoot
    bootrec /rebuildBCD
  • I lost all Grub menus, so reinstalled it. - nothing changed, same error.

  • I created a thread in the Microsoft Forums: 8195-6d4ed831f805 - however I couldn't find a solution.

Before I run chkdsk from the USB repair disk I wasn't able to mount the Windows (NTFS) partition from Ubuntu. I was getting a "couldn't mount file system, error code 2" error. I tried to fix the NTFS partition from Ubuntu but got a "segmentation fault". I also created a thread on ubuntuforums for this mount problem:

After chkdsk, I was able to mount the Windows partition but all I see in this partition is chkdsk logs, no any other data.

I don't think I lost my data because I didn't get any filesystem errors, just the boot section, but this log files under the Windows partition makes me afraid.

Microsoft developers don't have a solution yet for this error.

share|improve this question

migrated from Nov 6 '10 at 0:25

This question came from our site for professional and enthusiast programmers.

Could be an issue with the Bios incorrectly setting the ide configuration. For example if you have installed in IDE mode an the moved to AHCi. Happen to me one time. Changed back to the correct setting, system booted fine.

share|improve this answer

I had the same problem with my HP laptop. I found a solution for this problem, but it will erase your installation partition. I had two partitions C: and D: - my installation partition was C: when I got a message like you:

Windows failed to start. A recent hardware or software change might be the cause. To fix the problem:

  1. Insert....
  2. .... ... status : 0xc000000f info : The boot selection failed because a required device is inaccessible ....

I used Active@ KillDisk to erase the C: partition and left the D: partition. After installing Windows 7 again on the C: partition, everything works fine.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .