Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

As I type, the letters move to different sentences, breaking those sentences and destroying the sentence I'm typing. This is happening in Word, Facebook and E-mails. I can't finish a sentence without it happening at least twice! some have mentioned to disable the Touchpad, but in Windows 7, there doesn't seem to be a way to do it with this Acer laptop!

share|improve this question
Most touchpad software has a option to detect accidental detection, I would very much expect Asus touchpad software to do this – Keltari May 21 '14 at 20:54

On acer laptop you will have to press FN key and the key mentioning mouse sign to disable/enable mouse pad. Search the mousepad sign on Keys from F1 to F10 keys.

share|improve this answer
On Acer laptops it's usually Fn+F7 – Linker3000 Nov 6 '10 at 10:11

Is there an option to disable the touchpad in the BIOS -- typically accessed by pressing del, f8, or f12 during bootup?

Beyond that look for newer touchpad drivers from the manufacturer's website, they may offer something like what Synaptic does:


The PalmCheck™ feature guards against unintentional cursor movement and tapping caused by accidental contact of the palm or hand with the TouchPad. PalmCheck allows the TouchPad to recognize when a user’s palm is resting on it or brushing its surface while typing. This helps prevent unwanted pointer movement or clicks.

However, this will only work if your touchpad is a Synaptic model.

share|improve this answer

Try TouchFreeze utility: it block all mouse and touchpad clicks within short interval after every key press:

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .