Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I had a broken disc with a 40GB NTFS partition and was able to recover most of it. I only lost about 2.5MB at about 20 different places.

Now, when I mount it under Windows, I am not able to access "Documents and Settings" anymore. It says it is broken. Windows chkdsk also does not help. When I mount it under Linux, it says something similar.

All other directories (including "Windows") are just fine to access. But all the important data are in the documents directory.

Now I am wondering about my options. On Linux, if something similar happens for example on a ReiserFS partition, I can do something like ReiserFS' rebuildtree option which will work in almost all cases, even if very much data is corrupted. Is something similar for NTFS possible?

Thanks, Albert

share|improve this question

2 Answers 2

You didn't mention what the original OS was. You may be able to get in using the short file name.

In an elevated command prompt, assuming F: is the drive in question, type:

dir f:\ /x

This should show you the short file name, which is usually "DOCUME~1". See if you can get into it by typing:

f:
cd \DOCUME~1

Good luck!

share|improve this answer
    
Curious: How does the original OS matter? But it was Win XP. I already tried your suggestion and it doesn't work (and I would wonder if it really does or why Win chkdsk would not be able to fix this then). –  Albert Nov 7 '10 at 11:17
    
It matters because Windows stores the user settings under a different folder in Vista and Windows 7. Documents and Settings becomes a pointer record with different privileges anyway. But yes, CHKDSK should fix it. –  user3463 Nov 7 '10 at 18:26

You may want to look at scrounge, which does file recovery on NTFS partitions. The ntfsfix program from the NTFS tools may help too.

share|improve this answer
    
Already tried ntfsfix and didn't helped. But I will check out scrounge. –  Albert Nov 7 '10 at 11:17

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.