Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I accidentally removed the sata cable from a 2TB drive while booted into Windows 7 (don't ask) after rebooting back into Win 7 it now says I need to reformat the disk to use it.

I booted into my Ubuntu partition and checked it in there, the data is all there and the partition looks ok in gparted. I also tested it in testdisk and that showed no problems.

I'd like to get the drive working again in Windows 7 without having to reformat it as I don't have enough space to backup the data before reformatting.

Any help would be greatly appreciated.

EDIT: When I use Acronis Disk Director the drive is showing up as 128GB

EDIT 2: I've reformatted the drive in Ubuntu (NTFS) and it still refuses to work in Win 7

My setup is as follows:

500GB HDD - Primary bootable, 2 partitions
1TB HDD - 1 partition
2TB HDD << Broken

share|improve this question
    
I really do want to ask why you did that, even though you say I shouldn't –  Default Nov 6 '10 at 13:56
1  
I added the drive some weeks ago and never got round to putting the side of the case back on. I decided to put it on today and knocked the cable. Yes the computer should have been off but hindsight is a bitch ;) –  digital Nov 6 '10 at 14:02
    
hehe, tough luck.. Oh well, we always learn from our mistakes :) hope it gets resolved, unfortunately I don't know the answer to this one. –  Default Nov 6 '10 at 14:26

3 Answers 3

up vote 0 down vote accepted

The problem might be that the firmware of the hard disk became corrupted.

See this article : Restore factory Hard Drive Capacity When HDD Shows up as 32MB, which says :

We don't have a good technical explanation for what causes this issue to randomly strike PC users, but suffice to say a portion of the drive firmware known as the LBA48, HPA and DCO records becomes corrupted.

This solution uses the Atola Technology HDD Restore Capacity Tool to fix the firmware.
Use with caution and save first all data on the drive via Ubuntu.

Another possibility is that the disk was Partitioned originally in a system that did not support 48-bit LBA large-disk support (LBA48) and no drives larger than 137 GB (in other words: Ubuntu has not formatted correctly the NTFS). Even though it is now installed in a machine that does handles a large disk properly, it still has only one partition of size 137 GB to work with. The rest of the drive is simply undefined. There are three choices, but both of then go through Windows rather than Ubuntu:

  1. In Windows under Administrative Tools for hard drives etc, find the HDD. It should show you that it has one partition of 128 GB plus a bunch of unassigned space. You can tell it to create on this same HDD a second Partition of whatever size you like, up to a max of available space, and format it for you. It will become a third hard drive, as far as Windows is concerned. All the data on the 128 GB existing partition will still be there.

  2. Alternatively, in that same place, you can tell Windows to destroy the existing partition on that drive (you will certainly LOSE all its data!). Then tell it to create a partition on the unassigned drive of whatever size you want, up to the full size.

source

share|improve this answer
    
Thanks I tried this and the app said that it already had max capacity. –  digital Nov 7 '10 at 12:50
    
I have added a second possibility. –  harrymc Nov 7 '10 at 14:25
    
I've deleted the partition and it's now formatting it to 531.82GB. The format failed but it's now showing as healthy, when I try to use it it's still saying I need to format. –  digital Nov 7 '10 at 15:34
    
I've managed to get it working again. Not sure how but this answer made me go through everything logically. –  digital Nov 7 '10 at 16:11

Whatever you can do whith your disc using Windows XP/Win Vista/Win 7 can be found in Start/Config/Adminstration Tools/Computer Manager in left column you can find The Disc Manager. There you'll find your disc. You may have to activate the disc or resign disc letter. If nothing helps check behind your harddrive for jumper settings. Some drives have jumper settings that limits the drive. Have you the latest BIOS? Many harddrive problem have to do with the motherboard BIOS.

share|improve this answer
1  
Thanks for replying but I really don't think you read my question, I'm not using Windows XP the post states Windows 7 3 times and it's even tagged Window-7. When looking in disk management it shows up as 128gb as well which isn't correct, I can't activate the drive either. –  digital Nov 6 '10 at 15:55
    
I have many time disconnected my harddrives by unpluging the SATA cable or powercable. I have never had any problem doing so. –  Amir Rezaei Nov 6 '10 at 16:03

http://www.sevenforums.com/tutorials/681-startup-repair.html

You might not be able to dual boot after repairing the Windows 7 startup. I assume your using the Linux boot loader to control which OS you boot to so you might have to set this up again.

share|improve this answer
    
Is the 2TB drive the only drive in your computer? –  MHrappstead Nov 6 '10 at 16:52
    
No I'll update the op with the full setup –  digital Nov 7 '10 at 12:51

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.