Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a couple of Windows laptops with wireless network adapters.

One of them, let's call it Laptop1, runs Windows 7 Home, and has a broadband connection, which is shared via the Internet Connection Sharing thing. (Network Sharing Center... Manage Network Adapters...right click on the broadband adapter, click Sharing tab, then check the "Shared" box). The goal is that any wireless client in the area should be able to get an IP from the laptop with the broadband connection.

This works. I can connect to the internet from Laptop1, and also via Laptop2, which runs Windows Vista Enterprise, and uses the shared network.

However, I sometimes cannot use Remote Desktop to connect from Laptop1 to Laptop2.

The problem is intermittent. At all times I can ping the IP of Laptop2 from Laptop1. I can also ping via the (short) Laptop2 hostname. But when I bring up the RDP connection applet on Laptop1, it tells me it cannot connect. Sometimes!

And sometimes it does work.

I don't understand why the behavior is intermittent.

This morning, I tried connecting via the hostname. The RDP client dialog pre-populated a username for me. It would not connect. I tried again, and deleted the pre-populated user name. It connected successfully, and I authenticated with the username that had been pre-populated. Then I disconnected, and tried again, and I couldn't connect regardless what combinations of options and usernames I tried. What is going on?


I'd like to learn some approaches for troubleshooting RDP connection issues. Is there a log that Remote Desktop keeps describing connection attempts and what happened to them?

I'd also like to know the meaning of the Remote Desktop (Terminal Services) registry keys, so I can try tweaking those.

I'd also like to understand if there are ways to "open up" the security on RDP. If this is a security thing blocking my connections, I really don't want it!

Could it be the Windows Firewall? How does the firewall interact with the "network location" concept in Windows? Is it possible that when connecting to the shared network over Wireless, the Laptop2 thinks it is a "public" network and is then disallowing RDP? How do I fix this?

share|improve this question

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.