Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I had two desktops, one XP and another Vista. The XP machine started to freeze frequently and eventually refused to boot. Repairing it didn't work so I decided to transfer the files from the hard disk I needed and then reinstall XP afterwards. I connected the disk to the Vista machine to transfer the file (most are in the profile folders).

Every time I try to access the profile folders on the old disk, Vista is telling me I don't have permission to access it. The security tab lists some Unknown Users having full control for these folder. I am unable to change the permission for those folders.

I am doing this as an administrator on the Vista machine. All I want to do is copy the files from the XP profile folders on the old disk to the Vista PC. Can you help please?

Thanks

share|improve this question

3 Answers 3

up vote 0 down vote accepted

I had this same problem but with windows 7, from what I understand this fix will work for Vista as well. Open up an elevated command prompt (right click CMD>run as administrator) type in "net user administrator /active:yes". Log out and use this administrator account to take ownership and assign your user account full control permissions.

share|improve this answer
    
Diffuser, Kyle thanks for the help. This CMD allowed me to login as Admin. Then I could take ownership of the files. –  Sivakanesh Nov 11 '10 at 1:13

Have you tried to change the owner of the folder instead of just adding your account to the security list? If you right click the dir, go to properties, look at the security tab and then hit the advanced button there should be an owner tab. Any accounts listed there are likely local accounts from your XP box. Try adding your Vista account to that list and make sure you check the box that says apply to subcontainers and folders then see if you are able to access the folder after it gets done setting the new permissions.

share|improve this answer
    
I have tried that, but the problem is I get a message saying that I do not have permission to apply these changes from Visa. Somehow I need to remove the previous permissions on the XP profiles folder, but not sure how to :( –  Sivakanesh Nov 6 '10 at 21:21
1  
Note that if you have User Account Control enabled, you need to take ownership from an elevated Windows Explorer (one that is lauched with the "Run as administrator" option), since by default administrators behave as limited users in Vista and higher. –  Alberto Martinez Nov 7 '10 at 18:00

If the XP computer still boots, install the disk on it again and try the following:

  1. Create a folder in the root the disk (for example C:\profiles). Check that All users has at least read permissions on that folder.
  2. Copy (don't move) the profiles to that folder. By default, when you copy files they will use the permissions of the destination folder, but when you move them they retain the original permissions.
  3. Reinstall the disk in the Vista machine and cross your fingers.
share|improve this answer
    
Thanks, but the XP disk won't boot. I have tried to fix it for two days now, but won't work. There must be a way to remove the permissions on these folders! –  Sivakanesh Nov 7 '10 at 13:58
    
Thanks, Sounds promising. Will give that a go tonight. –  Sivakanesh Nov 10 '10 at 8:42

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.