Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Ok my question is kind of detailed. I tried the new Ubuntu a month or two back, but when I installed it it could only see my SSD as a valid installation point. So I installed it on there, and it seemed to run ok.

My problem is my SSD is on the smaller side (64 GB), I also have a WD Black, and a Samsung Spinpoint (750GB each) with basically the exact same memory spin/data rate etc. So I did not like Linux being on the SSD. The way I have my drives partitioned is one has a Programs/backup partition, both of the 750 GB run a 5Gb virtual memory partition, the other 750GB is media and another Backup.

So over all I have 64GB SSD for Windows 7, 750GB WD 5GB VM\693.63 Media, 750GB Spinpoint 5Gb VM\ 393Gb Programs\ 300GB Backup. I got a copy of openSuse 11.3 and Linux Mint 9 on a dual side DVD. When I try to install either it only see's the SSD. I want to run openSuse 11.3 Again when I try to install either (I tried Mint when Suse could not see my other HD's), it only see's the SSD. The other two drives do not show up at all during the install no matter the format I make a new partition with?

So I am basically dead in the water unless I want Linux taking up space on my SSD?

share|improve this question
    
So your question is just "How can I make my HDDs, and not just the SSD, visible to Linux installers?"? Nobody cares about the contents of your hard drives. Sorry. –  Daniel Beck Nov 6 '10 at 20:23
    
The disk brands don't matter here. What matters is the controller they're connected to. Your problem is perhaps that it's not supported by Linux. What is it? You may be able to see your hard drives if you connect them to a different controller or change a BIOS setting. –  Gilles Nov 6 '10 at 20:45
    
Any luck finding the disks? –  Alex Nov 9 '10 at 18:32

1 Answer 1

You can find what disks linux sees by going into the terminal and doing

sudo fdisk -l

You will see that hard drives usually have names assigned to them like sda, sdc, etc. The partitions are listed as numbers after it. So sda1 is the first partition of the sda disk.

If you don't see the hard drives, then your controller didn't find the drives as others have mentioned. I have never experienced this personally outside of Linux not understanding a RAID array.

Once you get the names of the drives, its time to mount them. You need a mount point (directory) to mount them to. Traditionally Ubuntu mounts in the /media directory.

sudo mkdir /media/my_first_disk

This creates a directory in /media called my_first_disk.

In order to mount to that directory...

sudo mount /dev/sda1 /media/my_first_disk

sudo means you run at higher privileges; mount is the command; /dev/sda1 is the path of the disk you want to mount ; */media/my_first_disk* is the destination you want to mount to

You can repeat this for many disks. You need a directory for each disk! After mounting they may show up on the desktop (at least they do for me). Note you need to mount the directory and not just the disk. In other words mount /dev/sda1, not /dev/sda.

This is only temporary. In other to have them mount every time, you need to add them to /etc/fstab. This is a little trickier. Check out this link for that. You can google more on that.

Hope that helps a bit.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.