Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

On my new build I just installed Windows 7 x64 and realized that I had put it on the wrong partition. I pop my OS CD back to re-install. My keyboard will work to access the BIOS but when the little message comes up to "press any key to boot from CD..." I can't do anything! If I let it go ahead and boot Windows it will work.

What I have tried:

  • Clearing the CMOS by hitting the button on the back of my computer.
  • I tried a different USB keyboard but it didn't work either.
  • I tried using one of those USB/PS2 adapters but I had the same problem.

Any other ideas what to try? I'm about out!

share|improve this question
    
I haven't experienced that, but a possible workaround to try, you could try a PS2 keyboard, they work a bit differently, you may notice that with a a ps2 keyboard they flash as soon as they are plugged in, so a slight sign of them working when plugged in! I doubt it'd work. But worth a try. It looks like maybe it's not a ps2 or usb issue. I'm not entirely sure whether that "press any key to boot from CD." is from the BIOS or the CD, I think it's from the CD, though that doesn't help. –  barlop Nov 6 '10 at 22:50
    
But to install windows you could just make it so it can't boot the current windows off the hard disk . Remove the current one , or make the partition of the current one inactive. –  barlop Nov 6 '10 at 22:51
1  
have you disabled Legacy USB in the BIOS? –  Xantec Nov 6 '10 at 23:21
    
Side note - that message "press any key to boot from CD" - it's from the CD. It's Windows way of trying to prevent you from booting off the install CD again after Setup invokes a reboot after the initial phase of the install. –  ultrasawblade Nov 7 '10 at 1:45
    
@Xantec: ENABLING that setting proved to be the solution. –  Icode4food Nov 8 '10 at 13:36
show 1 more comment

1 Answer

up vote 4 down vote accepted

The solution was to enable the "enable legacy USB keyboard support" in the bios.

I think that it actually didn't work the first time like I thought it did. My theory is that what happened then was that there wasn't anything bootable other than the CD so it automatically booted to that.

I'm not sure why I had to do this but it work so I can't complain!

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.