Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've looked at other posts with similar keywords, but none of them seemed to apply quite right.

(I have a Macbook purchased in June 2008)

I am able to use my home wifi, the wifi at my mom's house, and even my neighbor's unsecured connection.

However, every public wifi spot I've tried to work at fails. I AM ABLE TO "connect" to the network (Airport shows I am connected), but when I open a web browser I get a "Not connected to the internet" message. This has now occurred at four different locations. (Also, at one of them, I tried to connect with my iPod touch, and i was able to get online without issue.)

Also, when I first bought this macbook, I did not have this issue.

Any helpful suggestions? Thanks!

share|improve this question
    
When you connect to these public wifi spots, do you get an IP address? Are they the type of wifi spots that require a sign-in in the browser after you connect? – fideli Nov 7 '10 at 14:34

Do you have a static IP address assigned to your Airport interface for some reason? How about statically assigned DNS numbers? If that is the case, it might be a coincidence that the assigned address information is compatible with the neighbors's and mom's networks.

Try making a new network location. Go to System Preferences >> Network pane. At the top there is a pull down menu for Locations. Pull it down and select Edit Locations. Make a new location named Test. Click on the Apply button in the lower right.

This will give you a completely new network configuration with all interfaces set for DHCP. You may always change the location back to whatever the old one was if you need to.

share|improve this answer

I had the same problem.

The key for me was that I had a custom DNS server configured. In my case it was googles (8.8.8.8). I remember doing this some time ago for whatever reason.

Anyway, the public hotspots don't seem to like this. After removing the custom DNS server I was able to connect fine on public hotspots.

share|improve this answer

For those trying to connect to The Cloud Wifi and finding this page, I found some sort of potential workaround.

I found that none of the solutions like connecting to the router or deleting DNS entries worked.

Visit: https://service.thecloud.net/service-platform/configuration-profile/?brand=cloud&callbackUrl=cloudfastconnect%3A%2F%2Fhome

This will direct you a mobile site. Follow the instructions and download the profile. Open your downloads in Finder and double click the profile. You should now be able to navigate to any website and be redirected to the mobile launch page. You will need to create/log into an account, but after that you should be on the network.

share|improve this answer
    
Oh sure. The mobile app for The Cloud opens that link in the browser (with a few more arguments) when you select the option to install an automatic connection profile. I stripped out the token and MAC address arguments and it seemed to work. The website itself is just a basic page with a "download profile now" button. If anyone (rightfully) has suspicions about this, the page is in https, so you can look at the certificate and verify that it's legit. – JamEngulfer Dec 17 '15 at 15:07

protected by JakeGould Dec 17 '15 at 5:19

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.