Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a Compaq Desktop with a Compaq keyboard. The problem is from Friday, all of a sudden the following keys do NOT work. (Keys 1, 2, 3, 4, 7, 8, 9 and 0).

What I have done so far:

  1. Took the keys out
  2. Cleaned the keys
  3. When I were to press the inner membrane with a pen cap, there is no result. So, I doubt that it is a problem with the actual key (which I have popped out). This, I checked by putting the 1(!) key into the 5 slot and it actually works.

How can I check if the connectivity or the sensor(?) (which is covered with a white membrane) actually works or if there is a genuine problem?

The reason why I am asking this is, it is kind of strange that a specific set of keys in a row does not work. I mean, I can understand if the entire row did not work or if there was 1 key in a row which did not work...but how can

` (~), 5 (%), 6 (^), - (_), + (=) work and the remaining keys not work?

share|improve this question
    
How I typed the paranthesis is anybody's guess. –  Kanini Nov 7 '10 at 2:31
1  
The "keys" you popped out are nothing but key caps. If you had put the 1 cap in the 5 position and it didn't work or you got a "1" instead of a "5" would have been really surprising. Have you tried the usual? Does this problem happen in more than one application? Reboot? Boot into safe mode (you don't say what OS)? If you have another OS or a LiveCD, do the keys work in that environment? Do the corresponding keys on the numeric keypad work? –  Dennis Williamson Nov 7 '10 at 9:16
    
@Dennis Williamson: Oh yes. The "keys" are indeed key caps. The OS is Windows, but I have VM of Ubuntu and Mac running too (which is why the OS was not mentioned). Yes, the corresponding keys in the numeric keypad do work. It happens on all application - IE, Notepad, Wordpad, Word, Excel, Calculator etc., Reboot does not fix it. I have not tried booting in Safe Mode, will give it a try, but why should it work in Safe Mode? Any specific reason? –  Kanini Nov 10 '10 at 2:14
    
I only mentioned safe mode for the same reason I mentioned another OS, LiveCD or application - so you could test it in any additional environments. I'm not sure whether a VM would be a good diagnostic. It does sound like it's a hardware issue. –  Dennis Williamson Nov 10 '10 at 3:08
    
i had the same problem, i pressed the shift key and started pressing !@#%$%%%^^^ for some time and the problem was resolved. –  user129080 Apr 19 '12 at 8:21

1 Answer 1

up vote 5 down vote accepted

I'd gently suggest that the time already invested exceeds the value of a new keyboard... someone with a better knowledge of a circuit board & soldering iron could likely narrow it down, but i'd be shocked if anyone delves into keyboard repair.

share|improve this answer
    
i agree. keyboards can be had for under $20 so the time required to troubleshoot and repair one (unless you spent $100 on it) is probably worth more then a new one. –  Xantec Nov 7 '10 at 4:39

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.