Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm running Windows Server 2003 64bit edition. I've just installed the .Net 4 Framework in order to get a new WCF service up and running. However, I have no options anywhere in IIS 6 for selecting the ASP.Net framework version. I.e. Right click > Properties on the website should have as ASP.Net tab from where I should be able to select v2 or v4.

Does anyone know why they're not there and how I can make them appear? For the time being I've had to go into Website > Properties > Home Directory > Configuration and change the .svc extension to use v4.0.30319 instead. So, everything's now working for my WCF service, however every other extension is set to v2.

How can I get the tab? It's not visible on any of my 23 websites.

share|improve this question

3 Answers 3

Will the .NET 4 version of aspnet_regiis.exe work from the command line? You can use command line options to specify a specific web applications to be set (use aspnet_regiis -? to see command line syntax).

share|improve this answer

You need to create a new application pool that your .net 4 site will run under.

EDIT: That asp.net tab you're talking about doesn't do anything. It just allows you to change some configuration settings but you cannot use it to switch to .net 4. I've got multiple .net 4 websites running and the asp.net tab always shows the first entry: .net 2.0.*

share|improve this answer
    
This doesn't help at all. I'm already aware that .Net 4 needs to run in a separate pool, but there's no options anywhere for selecting the .Net framework version, hence my question. –  GenericTypeTea Nov 7 '10 at 19:43

From various websites across the Internet:

1) Confirm that ASP.Net 4.0 is disabled.

cscript iisExt.vbs /ListFile

2) If the entry for .Net 4 has a 0 on the left, then you need to enable it

3) Enable .Net 4 extension

cscript iisExt.vbs /EnFile C:\WINDOWS\Microsoft.NET\Framework64\v4.0.30319\aspnet_isapi.dll

4) Run the first command and you should have a 1 instead of 0 next to .Net 4.

You .NET Framework v4 apps should now run

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.