Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm using Teamviewer to help my family members with their computer problems. Sometimes they use the mouse and keyboard when I'm in the middle of something important. I don't want to tell them not to do it, instead I want to block their keyboard and mouse input when I'm connected to their machine.

I couldn't find an option to do this in Teamviewer preferences. Does anybody know how to do it?

share|improve this question
add comment

3 Answers

up vote 3 down vote accepted

On the computer itself you need to enable it in Extras>Options>Advanced>Advanced settings for connecting to this computer>Full access.

When you are connected to remote computer use Menu Actions - disable remote input

share|improve this answer
    
it doesn't work, it's grayed out –  holms Oct 14 '13 at 0:27
add comment

To be added to the current answer, you are better use

Disable remote input and show black screen. From action menu.

This way the remote computer will have a disabled screen, keyboard and mouse.

share|improve this answer
add comment

You do this from the remote computer after you have connected. When using Windows on the remote computer, Click on the "Actions" tab (Gear) at the top of the screen and select "Disable Remote Input". When remoting in from an Ipad, Click on the "Actions" (wrench) tab at the bottom of the screen and select "Disable Remote Input". I have not used Teamviewer on a Mac or IPhone so I am not sure of the exact steps. But it still should be under the "Actions" Menu.

share|improve this answer
    
it's grayed out in actions tab. –  holms Oct 14 '13 at 0:27
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.