Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My laptop windows 7 power settings are not working since last week, i have tried using "Dim display after 5 hours" and "Dim Never" also, but my screen goes black after 1 minute. Any resolutions ?

My laptop model is : Compaq Pressario CQ62

Graphics Card Information:

Name              Intel(R) HD Graphics
PNP Device ID   PCI\VEN_8086&DEV_0046&SUBSYS_1425103C&REV_02\3&11583659&0&10
Adapter Type    Intel(R) HD Graphics (Core i3), Intel Corporation compatible
Adapter Description Intel(R) HD Graphics
Adapter RAM 1.21 GB (1,303,306,240 bytes)
Installed Drivers   igdumd64.dll,igd10umd64.dll,igdumdx32,igd10umd32
Driver Version  8.15.10.2119
INF File    oem17.inf (iILKM0 section)
Color Planes    Not Available
Color Table Entries 4294967296
Resolution  1366 x 768 x 59 hertz
Bits/Pixel  32
Memory Address  0xD0000000-0xD03FFFFF
Memory Address  0xC0000000-0xCFFFFFFF
I/O Port    0x00004050-0x00004057
IRQ Channel IRQ 4294967294
I/O Port    0x000003B0-0x000003BB
I/O Port    0x000003C0-0x000003DF
Memory Address  0xA0000-0xBFFFF
Driver  c:\windows\system32\drivers\igdkmd64.sys (8.15.10.2119, 9.85 MB (10,326,784 bytes), 4/21/2010 6:18 PM)

I am not able to solve my problem from any of the answers till now. The screen still goes dark and password screen appears after 1 minute of idle time.

share|improve this question

migrated from stackoverflow.com Nov 7 '10 at 14:12

This question came from our site for professional and enthusiast programmers.

    
This may sound basic, but change your power setting to maximum preformance. See if that helps. –  wizlog Oct 25 '11 at 11:53

4 Answers 4

up vote 1 down vote accepted

I know this is going to sound remedial, but is your screen saver coming on? It could be that it's just defaulting to "Blank" after 1 min. and displaying logon screen on resume.

Right click the desktop, select "Personalize", click "Screen Saver" on the bottom right. If you don't want it to turn off select "(None)" instead of "Blank"

share|improve this answer
    
didn't realize how old this question was till after I posted that answer... –  Daniel May 15 '12 at 3:26

Have you checked the screensaver yet? My Notebook had the same problems and I finally fixed it through the screensaver settings: Desktop, right-click, "adapt" or "customize" (my win7 is german) on the bottom, screensaver.

share|improve this answer

You are changing the wrong setting, try changing the setting for when your monitor must be turned off.

The dim setting would only decrease the brightness to spare a bit of energy, it doesn't make it black.

share|improve this answer
    
"Turn off the display", "Put the computer to sleep", "Dim the display" are three diff options in power settings and I have set them all to 5 hours. –  teenup Nov 7 '10 at 15:14
    
Ah, then it's probably some non-Windows setting, NVIDIA suggestions won't help here nor does that HP page seem to give information about the problem itself. Try updating the Intel(R) HD Graphics drivers or look if you are able to configure energy-related options for that in it's control panel... –  Tom Wijsman Nov 7 '10 at 16:28

I think maybe this is a duplicate of this question.

This was the accepted answer:

I found a solution in the NVIDIA Control Panel (right-click your desktop and select "NVIDIA Control Panel"). Under "Display" on the left-side menu, select "Adjust desktop color setting". On this screen, click "Use NVIDIA settings". My screen brightened up as soon as I selected this.this.

Could you give that a try? Let us know if it doesn't work out! It might be something else, but I guess it's worth a shot! Also, please provide us with some details about your computers specs (particularly the graphics card and the make/model of your laptop) - there might be some hints there as well!

Easy way to find detailed graphic card specs:

  1. Click the 'Start' button, in the 'Taskbar'.
  2. Type 'msinfo32' in the search field in the start menu, and hit 'Enter'.
  3. To find details about your graphics card; go to 'Components' -> 'Display'.
  4. Copy the 'Name' and 'Driver' information into your question.

Also, does your screen go completely black, or does it just dim down a lot? If it goes completely black, it might be a problem with the screen itself, the screens connection to the computer, or possibly an issue with your graphics card (or it's motherboard connection).

If the screen goes completely black; try turning the monitor slowly back and forth, and see if the screen "activates" at certain angles. If it turns back on at certain angles, it's probably a connection issue. In this case you should probably return it to the manufacturer for repair, if you can't repair it yourself.


Edit:

HP posted an article on the 23. of Aug. 2010, about issues regarding your laptop. This might be able to help you resolve this issue. If not; I suggest contacting HP customer support, if your purchase is still covered. One thing you could check first is if your firmware and drivers are up-to-date, and update them if they are not.

There is a section in the article, "Update your BIOS", which should take you through the steps of upgrading your BIOS. Be very careful when doing this though, and read the instructions thoroughly! Doing something worng when flashing your BIOS might damage it even further.

Also, the reason why you're not seeing any 'nVidia Control Panel' when you right-click on your Desktop is because you don't have an nVidia graphics card installed, as far as I can tell. I believe you're using your chipset's integrated GPU.

share|improve this answer
    
On right clicking my desktop there is no "NVIDIA Control Panel" option. Problem: If keyboard and mouse remain untouched for a minute, the screen goes black for 2-3 seconds and then it displays the windows password screen, then i need to enter the password and login again. –  teenup Nov 7 '10 at 15:10
    
I see. Then you might not have the appropriate drivers installed, if you know that you have an nVidia graphics card. The "how to" in my answer should tell you how to find the graphics card, as recognized by Windows. Else, it sounds like you're having an issue with the computer going to sleep. There might be some BIOS options overriding your preferences in Windows. Could you please update your question with the make and model of your laptop? (There might be a known issue with this particular laptop). –  Leif Nov 7 '10 at 15:14
    
Also, note that there are two different "sleep" options as well - one when your computer is powered by the laptop's battery, and one when the laptop is connected to the charger. Check out 'Power Options' from the Windows 'Control Panel'. Click 'Change plan settings' and make sure the 'Put computer to sleep' options are set the way you want them to be. –  Leif Nov 7 '10 at 15:19
    
All are set to 5 hours - On battery as well as On Plugged In –  teenup Nov 7 '10 at 15:25
    
I have seen the link, will read it and come back tomorrow. Thanks. –  teenup Nov 7 '10 at 15:28

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.