Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm using RDP to Remote Desktop from a Windows 7 machine to another Windows 7 machine, so it's RDP 7. I've got the colour depth set at 32 bits and can confirm that 32 bit colour is working properly because I'm able to use Aero over the remote desktop connection which requires 32 bit colour. I also connected to a 2008 server box at 32 bits and confirmed from the server side that the connection was using 32 bit colour.

The problem is images still look crap and have all sorts of colour banding as if they were still being sent as 16 bit images, even though the connection is supposedly 32 bits. I'm planning on using the connection for image processing and as such need the full colour depth in the images otherwise the environment is useless to me.

Ideas or experiences?

share|improve this question
    
don't use RDP for graphics processing...seriously. if you have some MONSTER computer that you want to use for graphics processing on the local lan, i would use a different desktop grabbing application(rdp might be set to a particular bit display but then try to "optimize" the graphic to make network traffic skinny). if it's going over a wan link - bad idea. –  hbdgaf Nov 8 '10 at 5:17
    
It's not going over a wan link, it's going over a gigabit LAN. Any way to turn all the optimization shit off? –  Matthew Hall Nov 8 '10 at 5:43
    
Also I need the dual screen ability of RDP. –  Matthew Hall Nov 8 '10 at 5:45
    
If you are domain joined, a System Administrator may have set a Group Policy setting that forces it to something less than 32-bit. They might do that for saving bandwidth, etc. –  vcsjones Nov 8 '10 at 6:11
2  
Rather than relying on the presence of Areo to check colour depth, why not check the desktop properties to get the depth directly (they''ll be readonly)? Both the server and client limits are applied, if the client asks for 24bpp, but the server limits to 16 (the default) then you'll get 16. –  Richard Nov 8 '10 at 6:58
add comment

2 Answers

This issue is about the RDP image compression. Windows 7 and Server 2008 R2 use a version where changes to compression and the codec etc were made, I believe, and there were changes made to it that cause banding and similar to occur even when you use 32-bit color (in the interest of higher speed, I presume.)

It is possible to change this; it will increase bandwidth and load and lower speed but it should alleviate the banding issue.

Setting a DWORD in registry at HKEY_CURRENT_USER\Software\Microsoft\Terminal Server Client\AllowDynamicColorFidelity with the value of 0 (in the client, not the server) will make the banding go away.

share|improve this answer
add comment

Experience: I had a similar issue recently. I had RDP set to run full screen which turned out that the resolution was too high to support 32 bit color, so it was dropping back down to 16 bit automatically and silently. As soon as I ran the remote desktop at a lower resolution, 32 bit color worked as expected.

share|improve this answer
    
Even at 640x480 I can still use Aero so the connection is 32bit but I'm still getting the colour banding. :( –  Matthew Hall Nov 8 '10 at 5:50
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.