Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Internet Explorer 8 on XP SP3 starts without browser window. Task manager doesn't show application, but iexplore.exe is listed twice in process window. Process Explorer reports "no visible windows found for this process" when I try to "bring to front" in the iexplore.exe properties dialog. Have reinstalled (twice), full scanned with MBAM/MSSE/SpyBot etc, re-registered ieproxy.dll (another Google-inspired tip!), run without addons (-extoff switch), and still same problem. Recently uninstalled VMWare Player and wondered whether problem related to VM network adapter somehow, but Firefox still works perfectly.

This is one of my home machines, not critical, and it is backed up, so I will restore if I have to. But any and all suggestions will be gratefully received. It would be nice to understand what might have happened, and perhaps others may benefit from any knowledge that comes to light.

share|improve this question
That's extremely strange. – the_drow Nov 8 '10 at 12:53
Have you gone into the Control Panel and reset the Internet Explorer settings to default? – user3463 Nov 8 '10 at 21:20
@Randolph Potter - many thanks for your suggestion. I had in fact tried that (Advanced Tab - Reset Internet Explorer settings) but I omitted to mention it in the question. I'm sorry about that. – Lord Peter Nov 9 '10 at 0:29

Have you tired uninstalling Windows Internet Explorer via Add Remove Programs and then reinstalling?
I had a smiilar problem recently on one of our staff machines, albeit with IE7. Rolling it back to IE6 (The horror) and then reinstalling worked fine for me.

share|improve this answer
Thanks for your suggestion, but I had already reinstalled IE twice (it doesn't appear in Add/Remove but reinstalling removes and reboots first). I eventually restored from backup but removing VMWare player again left me with problems, but found this: see "Manually cleaning up the system"… and everything now OK. So I suspect my uninstall of VMWare player was at fault. Odd that Firefox still worked though! I'll add a VMWare tag in case someone else has the same problem. – Lord Peter Nov 12 '10 at 20:08
@LordPeter If you have solved your problem, please answer your own question (and accept the answer). – Bob Jul 23 '12 at 7:52

Try this: Open cmd (As Administrtor). Type in this command: "sfc /scannow" without the quotes. Reboot, tell me if IE starts up again properly.....

share|improve this answer

This is often an indicator of Malware. I've seen bot nets display this behavior frequently. I would scan with the free versions of Malware Bytes, Super Anti Spyware(careful this likes to install a toolbar so unchecked it) and TDSS Killer. Start with TDSS Killer. If you really want to be deep use GMER after TDSS Killer. This most often resolves this issue if you've reinstalled IE.

Also you may want to check your start up programs using msconfig. Check for unusual non-Microsoft services and start up programs.

share|improve this answer
up vote 0 down vote accepted

@Bob has encouraged me to turn my comment of 2010-11-12 into an answer. I still do not know what caused IE 8 to start without a visible window, but after a thorough uninstall of VMWare Player, the problem went away.

VMWare Player installs a lot of devices and services and the VMWare knowledge base has very detailed instructions, which I am not going to copy-paste here. Please see their article "Cleaning up after an incomplete deinstallation on a Windows host" if you have similar issues.

After all this time, the problem has not recurred.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .