Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

In terminal my Volumes directory looks like this:

"Sanitized"-Computer:Volumes "sanatizedUserName"$ ls
Backup of "Sanitized"’s MacBook 	Macintosh HD
LaCie   				iDisk
LaCie-1

Somehow I have a duplicate "LaCie" drive and I can't access it to delete it. It is an Airport Drive. OS X must have a preference file somewhere it keeps of past network drives that I can delete.

It only mounts when the real drive is plugged in. I am afraid to delete this duplicate because it may delete real data.

I believe this "ghost" drive is screwing up my time machine backup.

Permissions:

"Sanitized"-Computer:Volumes "sanatizedUserName"$ ls -al
drwx------@ 26 root        wheel   840 Aug 10 18:41 LaCie-1

Thanks for any help.

share|improve this question

2 Answers 2

up vote 2 down vote accepted

Mac OS X mounts drives by default by creating a folder with the name of the drive in /Volumes and then mounting it at that point (so a drive is normally accessible via /Volumes/NAME_OF_DRIVE). Mac OS X will append a -# after the name of a hard drive if multiple drives of that name are mounted. (eg. /Volumes/NAME_OF_DRIVE-1 and /Volumes/NAME_OF_DRIVE-2, etc.) This will also occur if a folder exists in /Volumes/ by that same name. Even though the mount point has a different name the name of the drive will show correctly in the Finder.

An example of what can cause an erroneous folder:

A script or application that writes a file to /Volumes/ExternalDrive/somefile.txt or even an application that when checking if a file exists (eg. open last saved document) creates a new document at that location when the hard drive/network share/USB key/etc. is not mounted. The file will exists at /Volumes/ExternalDrive/somefile.txt meaning the folder /Volumes/ExternalDrive will exist when you next mount.

Fixing this:

  • Ensure all drives have been unmounted - use Disk Utility or diskutil list to be sure
  • Check to see what can be seen in /Volumes/ - recommended to use the Terminal and use ls -laF /Volumes. There should only be one folder (NAME_OF_STARTUP_DRIVE -> /)
  • Delete the remaining folders. (I'd recommend checking the contents first)
share|improve this answer
    
I know this is what happened: an app tried to write to the drive when it was disconnected. However, I had tried to delete this folder, but when time machine runs, it re-creates the folder. The "LaCie" folder has a minus sign (inaccessible). So it seems for some reason that Time Machine thinks that the backup is in "LaCie-1" not "LaCie". –  Corey Floyd Aug 11 '09 at 6:38
    
I also deleted all Time Machine permisions (backupd and timemachine) and time machine STILL created the LaCie-1 folder. –  Corey Floyd Aug 11 '09 at 6:39
    
I'd recommend unmounting the drives, remove any left over folders in /Volumes, turn off Time Machine then remount the Lacie drive and then re-select it using Time Machine. (Press Change Disk, change it to None, and then press Change again and select it properly) –  Chealion Aug 11 '09 at 15:30
    
I have tried that numerous times. ...time machine always recreates the drive. –  Corey Floyd Aug 12 '09 at 15:38
    
Is Time Machine saving your backups in a .sparseimage? –  Chealion Aug 12 '09 at 16:27

Ok, so I first turned off my drive to make sure nothing was deleted.

Then in terminal I typed:

sudo rm -rf Lacie-1

Great news, this works. I turned my drive back on and everything was fine.

I did find the cause however when I tried to do my time machine backup. Time Machine is actually creating this ghost drive for backups. I don't know why.

share|improve this answer
    
It's creating Lacie-1 because /Volumes/Lacie already exists. It's not related to Time Machine but how Mac OS X mounts external mounts (eg. external hard drives, network shares, etc.) –  Chealion Aug 11 '09 at 2:35
    
I guess you should have also removed the stuck mount point sudo rm -rf Lacie –  Munkymorgy Jul 9 at 19:11

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.