Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

It was working fine one day. Then on the next, I tried to access the store and received this message:

Your request could not be completed.
The item you've requested is not currently available in the US store.

I haven't requested anything. Closing iTunes and reopening doesn't help. Suggestions?

SOLVED: An upgrade from version 6 to v10 solved it. Thank you Alexandru and Kiwi.

share|improve this question
    
What Operating System are you running? –  Force Flow Nov 10 '10 at 6:41
    
@Force Flow:Vista (dun dun duh!) –  John Nov 10 '10 at 14:53
add comment

1 Answer

up vote 1 down vote accepted

Try logging out and back into the store (menu item Store > Sign Out) and see if that gets it working properly.

Also, if you ignore this message and keep using iTunes, are there any other problems?

share|improve this answer
    
It didn't work. No other problems that I know of. –  John Nov 11 '10 at 2:28
add comment

protected by studiohack Mar 13 '11 at 4:53

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.