Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I use Ubuntu 10.10 on a laptop. I changed the "blank screen" settings at "System preferences -> Power management" and "Screensaver" and when I am logged in I can close the lid without going to sleep.

However, when I am at the login screen where I can choose a user, the behaviour is different. Ubuntu hibernates when I close the lid.

How can I change this so that only the screen blanks when I close the lid at the login screen?

share|improve this question

2 Answers 2

up vote 2 down vote accepted

Go back to Power Management and click Make Default. The options will then be set for root (and default for all users), thus giving you the same behaviour when not logged in.

Power Management]

share|improve this answer

If you want to do this from the command line, set HandleLidSwitch=ignore in /etc/systemd/logind.conf.

Then do a service systemd-logind restart.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.