Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Windows 7 Explorer can be opened in any folder from the command line. But, it automatically expands (on the left nav panel) the Favorites, Desktop, and [Username] folders. This makes it hard to see what's what in the nav panel.

How can I tell Windows 7 Explorer to collapse those folders by default, until I open them? I only want the selected folder expanded.

share|improve this question
    
Update: It seems that Explorer remembers whatever folders were left expanded, and expands those each time. How do I have it start without expanding anything? –  SRobertJames Nov 10 '10 at 18:44
    
Would love to see an answer to this. When browsing folders with explorer.exe, not everyone wants them to be automatically expanded in the treeview. And at other times, we might want folders to not unexpand automatically when we click another folder. –  Robert Kerr Nov 17 '10 at 15:57
    
I would love to see a solution as well. My issue is this-I have a shortcut on my desktop to the root of my C: drive. I don't mind C: being expanded when I click on this link. What I do mind is that any folders on my desktop are expanded because I expanded them in a previous Explorer window and closed that window without collapsing the folder first. Windows "remembers" it was expanded in the other window so expands it when I click on my shortcut. I want Explorer to open with all folders collapsed (except for C:) when I click on the shortcut regardless of what happened in previous windows. –  sdoca Nov 3 '11 at 20:43
    
None of the answers are any good. The point isn't to make explorer not expand to the current folder, it's to make explorer show the current folder by not expanding a bunch of other default crap. Read the question folks. –  Eli Apr 11 at 18:42
add comment

3 Answers 3

If, in the same "Folder Options" dialog (which is also accessible by going to "Organize -> Folder and Search Options", if you have not changed the default from hiding classic-style menus), you also uncheck "Show All Folders", it will no longer display and expand the current User Folder every time you open an Explorer window.

This had also been my biggest pain in the tush, and I just recently found the solution through Windows 7's built-in help (by doing the opposite of what they suggested).

share|improve this answer
add comment

Try this - open Windows Explorer. Click TOOLS > FOLDER OPTIONS

Uncheck Automatically Expand to Current Folder

What command line switches are you using (if any) while opening Explorer?

share|improve this answer
add comment

In Windows Explorer click on Tools > Folder Options

In the General tab under Navigation Pane Uncheck "Show all folders".

Now when you open Windows Explorer you should get collapsed folders.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.