Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a HP TX2000 laptop and a HP w2408 screen. Yesterday, I installed Win7 and I'm having trouble having the 24 inches screen work as a secondary screen. It seems like my laptop cannot detect both screens (its own and the 24 inches one).

I think I already have all the drivers installed (I ran Win7's tool to detect and automatically update drivers and it said everything was up to date!), so what might be the problem?

If I connect the 24 inch screen to my laptop, it will happily show a copy of what is being shown on that big screen too, but I'd like to have it ''extend'' the desktop to the big screen, instead.

share|improve this question
Do you have an NVidia card or the integrated graphics? You might want to try setting up the displays either through the Nvidia utility or the Intel utility, just to see if it works. I had some problems with my latitude, it was showing 4-5 monitors in the windows display properties, but the Intel utility worked fine. – Not Kyle stop stalking me Nov 10 '10 at 19:26
Please, answer Kyle's question... – kokbira Nov 10 '10 at 23:37
up vote 1 down vote accepted

Go to the HP site and check for drivers there. Windows update is not always "correct" in picking drivers. I don't think there are Windows 7 drivers there but Vista drivers that may do the trick. There may be a driver from the card maker but some OEMs do things a bit different with the chipset and the driver gives issues. There may alos be an app that HP provides that manages the desktop/display but it is usually in the driver package.

share|improve this answer
I already tried installing them, but the problem remains. – devoured elysium Nov 10 '10 at 20:04

Have you simply tried using Windows + P? If you hold down the Windows key and press P several times, you can tab between the different options. Choose Extend (which is the third option).

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.