Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

A few days ago I was using autocomplete features and Ctrl-click without any problem.

But now those features don't work anymore: the autocomplete shows up but is always empty, and Ctrl-click doesn't work because Eclipse doesn't recognize the classes anymore.

This doesn't even work for a class or function or variable in the same file, so I guess this is not a configuration problem, but maybe a cache that is corrupted?

share|improve this question

3 Answers 3

up vote 23 down vote accepted

Try this:

  • Go to Preferences » Java » Editor » Content Assist » Advanced.
  • Make sure Other Java Proposals is ticked/checked

If that does not work simply "close" the project and reopen it.

share|improve this answer
1  
That did the trick thank you ! I am using Eclipse for PHP, so I tried closing and reopening the project and it worked. Exactly what I was looking for thanks. –  Matthieu Napoli Nov 11 '10 at 16:54
1  
Kepler didn't have this turned on by default when I downloaded it for some reason –  Jherico Jun 25 '13 at 21:59
1  
+1 same thing. Kepler didn't have this turned on by default. Hopefully other people will come by and see this fix. ( Eclipse Kepler Turn On Content Assist AutoComplete Intellisense) –  Daryl Teo Jul 6 '13 at 4:52
1  
I dunno why Kepler doesn't have this on by default. That's a must for android dev. –  noob Sep 20 '13 at 9:22
1  
Thanks a lot, you have saved me! I was getting crazy –  tangrammer Jan 13 at 20:12

This was a tough one for me to solve (running Juno Version: 4.2.1 Build id: M20120914-1800 on Mac OSX 10.6.8).

The steps I had to take were:

  1. Run Help » Check for updates and then restart to get to the most recent version
  2. As noted above, Go to Preferences » Java » Editor » Content Assist » Advanced
  3. Click everything Java related in both sections
  4. Restart again
share|improve this answer

On ubuntu studio the ctrl-space was assigned at the operating system level to change the keyboard input method. I had to change the Next Input Method in Settings Manager–>Keyboard Input Methods–>Next Input Method field.

I changed it from ctrl-space to ctrl-alt-shift-space.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.