Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

A few days ago I was using autocomplete features and Ctrl-click without any problem.

But now those features don't work anymore: the autocomplete shows up but is always empty, and Ctrl-click doesn't work because Eclipse doesn't recognize the classes anymore.

This doesn't even work for a class or function or variable in the same file, so I guess this is not a configuration problem, but maybe a cache that is corrupted?

share|improve this question
up vote 29 down vote accepted

Try this:

  • Go to Preferences » Java » Editor » Content Assist » Advanced.
  • Make sure Other Java Proposals is ticked/checked

If that does not work simply "close" the project and reopen it.

share|improve this answer
That did the trick thank you ! I am using Eclipse for PHP, so I tried closing and reopening the project and it worked. Exactly what I was looking for thanks. – Matthieu Napoli Nov 11 '10 at 16:54
Kepler didn't have this turned on by default when I downloaded it for some reason – Jherico Jun 25 '13 at 21:59
+1 same thing. Kepler didn't have this turned on by default. Hopefully other people will come by and see this fix. ( Eclipse Kepler Turn On Content Assist AutoComplete Intellisense) – Daryl Teo Jul 6 '13 at 4:52
I dunno why Kepler doesn't have this on by default. That's a must for android dev. – noob Sep 20 '13 at 9:22
close/reopen worked for me. – dharm0us Jun 5 '14 at 11:18

This was a tough one for me to solve (running Juno Version: 4.2.1 Build id: M20120914-1800 on Mac OSX 10.6.8).

The steps I had to take were:

  1. Run Help » Check for updates and then restart to get to the most recent version
  2. As noted above, Go to Preferences » Java » Editor » Content Assist » Advanced
  3. Click everything Java related in both sections
  4. Restart again
share|improve this answer

On ubuntu studio the ctrl-space was assigned at the operating system level to change the keyboard input method. I had to change the Next Input Method in Settings Manager–>Keyboard Input Methods–>Next Input Method field.

I changed it from ctrl-space to ctrl-alt-shift-space.

share|improve this answer
Thank you so much, this was driving me nuts! – Darhuuk Sep 17 '14 at 20:34

You must log in to answer this question.

protected by Mokubai Jun 7 at 17:07

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .