Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

When I have multiple Chrome windows open, Docky correctly groups them into one icon on the dock. However, what I want to do is launch a Chrome application launcher (with the --app= command line switch) and have it launch to a separate icon that operates completely independently from my regular Chrome icon.

I can currently achieve only part of this. Following the advice here ( I created the following launcher for Gmail, with an altered StartupWMClass, which I then dropped onto the dock:

#!/usr/bin/env xdg-open

[Desktop Entry]
Exec=/opt/google/chrome/google-chrome --app=""

That launcher does create a separate icon in the dock, and that icon only contains the application mode window created by this launcher. However, my pre-existing Chrome launcher also matches the application mode window and snares it as well. For example, if I have three regular Chrome windows open and click the Gmail launcher above, the Gmail icon will only contain the application mode window, but the regular Chrome icon will now contain four windows.

Is there something else I can do to make the application mode window ONLY match to the application mode launcher?

Currently on a machine with Ubuntu 10.04 and Docky 2.1.0 from the Docky PPA.

share|improve this question
up vote 3 down vote accepted

Paste this code below into the command line, it should work fine. google-chrome --user-data-dir=~/.gmail --app= --class=Gmail $*

share|improve this answer
Fascinating @Orlando! The combination of class AND the separate user-data-dir seems to branch it off... into the same group as whatever terminal I'm using. :P Putting the launcher in Docky spawns a new icon, and when launching it from GNOME, there's no option to pin to dock. Any tips for getting it to persist to the dock? – Calvin Fisher Mar 28 '11 at 0:01
I wouldn't be able to tell you.. I don't use gnome. However, I think there is a workaround for the docky problem somewhere in launchpad. EDIT: found it – Orlando Mar 28 '11 at 19:26

Add --class=chrome-gmail at the end of the command line.

share|improve this answer
Care to explain what flag that enables @brx? – Ivo Flipse Jan 28 '11 at 15:18
Unfortunately, that doesn't seem to work. The window is still grouped with other Chrome windows. – Calvin Fisher Feb 14 '11 at 17:43

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .