Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I recently upgraded Fedora 12 to 14 and I can no longer login as root from the GUI login screen. I choose Other, but no dice. I know that it is bad practice to do this normally and that is probably why it was implemented, but it's a VM in a closed environment.

So how can I enable the root user in Gnome for Fedora 14?

share|improve this question
add comment

5 Answers

up vote 3 down vote accepted

Well you should have a secondary user other than root on the system to login with. Hopefully that user is in the sudoers file and has root permissions or is a part of the wheel group?

If the above criteria is met you can do the following from terminal:

sudo vim /etc/pam.d/gdm

Then comment out this line:

#auth       required    pam_succeed_if.so user != root quiet

Then open this file:

sudo vim /etc/pam.d/gdm-password

Then comment the following line (same as the above):

#auth       required    pam_succeed_if.so user != root quiet

Log out of that account and login in as root using the "Other" option. You will get some long winded alert about how it is not secure to use the root account, just close and you are in!

share|improve this answer
    
From @ricbax comment it appears that you need to configure 'another user' equivalent to root and not to login as root user. May be a way to reduce use of root password which could be seen by anybody while you type?? –  GuruM May 3 '13 at 13:57
add comment

Searching for "Gnome enable root login" provided this snippet:

To permanently enable root login to gnome under Debian, edit the /etc/gdm/gdm.conf file.
In the [security] section of the file, add the following line:
AllowRoot=True

share|improve this answer
    
I am using Fedora not Debian. My gdm.conf also does not have a [security] section listed in the file. –  tbird Nov 11 '10 at 23:06
add comment

There is a way with screenshot and brief description of enabling root user in fedora 14 link click here

share|improve this answer
add comment
sudo su
passwd

done.

share|improve this answer
add comment

On Fedora 17 one can logon as the root user although I advise against it unless you really, really, really have to do so. One mistake can trash your entire system or force you to have to reinstall something.

  1. Hit Ctrl+Alt+F2 (or try to use some other tty if that one is unavailable by trying alternate function keys).

  2. Logon as root and type in your root password when asked.

  3. Type startx and press Enter.

  4. Do your administrative stuff.

  5. Log out of Gnome shell.

  6. Type exit and hit Enter.

  7. Hit Ctrl+Alt+F1 to return to your current logged-on desktop (or use alternate until you get back to the one you were on if that one is not where you were; this can happen with boot errors before the X server loads).

I have been doing this for quite some time and this has worked well for me using Fedora and Gnome 3 shell.

They may plug this one up some way but for now this is what I do when I want the super user to get logged on and using the window manager.

The preferable solution is to use sudo for commands, su -c [command line executable and options] or just su to do most of your administrative stuff, so keep that in mind. But this above solution can be done if you really need it.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.