Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

This problem began when I noticed that the icons in the Windows 7 task bar for MS Word and Outlook were generic. I rebuilt the icon cache. Still not the right icons, but not the generic "document" icons either, and both are identical (to each other). The two programs seem to be working OK.

So then I tried to repair MS Office. I ran the setup file. It extracts the files, I get the splash screen, and then the message, "Setup has stopped working. A problem caused the program to stop working correctly. Windows will close the program and notify you if a solution is available." with a "Close program" button. Microsoft does not notify me about a solution.

What I have tried: 1. running two other copies of the setup program; 2. doing an in-place re-install of Windows 7.

share|improve this question
    
Have you tried uninstalling Office? –  Moab Feb 19 '11 at 23:00
add comment

1 Answer 1

It sounds like something has "stuck" around from an earlier installation: either in the registry or the file system. You can spend quite a lot of time trying to re-install, uninstall etc. You could call Microsoft Support. They have some tools that are targeted to cleaning specific libraries, files, DLLs etc. Bear in mind, that might be a long call, so find some spare time.

What I usually do is:

  1. Backup essential data.
  2. Try restoring you OS to a point in time when Office ran well.
  3. If that doesn't work, try one or two more restores, going backwards in time - again, remember to backup files or programs that may have changed since!
  4. If all else fails, you may have irrevocably screwed your Windows 7 installation somehow and may have to reinstall it from scratch.
share|improve this answer
    
Yes. I sense what you're saying. –  Len Nov 12 '10 at 3:26
    
Interestingly enough, before I re-installed the OS, I tried System Restore, and found that it had been totally turned off and all my previous restore points were gone! –  Len Nov 12 '10 at 3:27
    
Ouch! I found out that some of my restore points got corrupted somehow. And guess which one did I need... –  Traveling Tech Guy Nov 12 '10 at 7:02
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.