Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Possible Duplicate:
SSH asks for password, even with public key installed

http://rcsg-gsir.imsb-dsgi.nrc-cnrc.gc.ca/documents/internet/node31.html

I am trying to login from machine A to machine B with password-less SSH login as described in the above link.I have followed all the steps but still the password is being prompted for.How to diagnose this and resolve the issue

share|improve this question

migrated from stackoverflow.com Nov 12 '10 at 0:43

This question came from our site for professional and enthusiast programmers.

marked as duplicate by Arjan, Diago Nov 20 '10 at 7:35

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

1  
Better to ask this on serverfault.com? –  knitatoms Nov 10 '10 at 10:24
    
@knitatoms, please don't invite people to repost their question on another site. Things will be moved automatically if people vote for that. No need to ask for duplicates! Thanks! –  Arjan Nov 20 '10 at 0:19

2 Answers 2

You need to edit: /etc/ssh/sshd_config (or equivalent for your distribution)

And make sure the following lines are set as shown:

....
ChallengeResponseAuthentication no
PasswordAuthentication no
UsePAM no
...

Be careful though - you could lock yourself out. Here's a good guide:

http://www.debuntu.org/ssh-key-based-authentication

share|improve this answer
    
@Knitamatoms:On which machine this should be done –  Rajeev Nov 10 '10 at 10:35
    
Machine B if that is the one you are connecting to. –  knitatoms Nov 10 '10 at 18:34
    
@Knitamatoms:I believe thats not the problem ,bcoz i have configured another machine with the options mentioned as yes –  Rajeev Nov 10 '10 at 18:48

You can still keep password-based authentication (PasswordAuthentication Yes) and use keys when you have them. I have a box here for shared git that we all use our own ssh keys (using .ssh/authorized_keys) but my user account I login with a username/password. The key is adding the public side of the key to .ssh/authorized_keys file on the server you want to login to remotely.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.