Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I just received my new Asus EeePC 1001px netbook. After installing Ubuntu 10.10 on it, I've noticed that my hard drive is making a clicking noise. Now this is not a loud clicking noise nor it's constant (only sounds occasionally and when hard disk is not writing or reading anything). Another strange thing is, this only happens when netbook is using battery power, the moment I plug in AC power clicking stops. Additionally I noticed that when I go into BIOS I can hear the click only once, same thing happens if I boot Ubuntu from USB. That led me to believe the problem is within operating system.

I did all the surface scans and SMART tests and everything seems to be fine. Now noise sounds like heads are trying to "park" themselves so I tried disabling "spin down" option in Power Management but it didn't help.

Any idea?

share|improve this question
up vote 1 down vote accepted

I have the same problem, and in the next week will try to find which daemon set it.

What do these commands say?

sudo smartctl -d ata -a /dev/sda | grep Load_Cycle_Count
sudo smartctl -d ata -a /dev/sda | grep Power_On_Hours

To turn off spin down (it is dangerous when your laptop is failing) use:

sudo hdparm -B 255 /dev/sda

Important details can be output from this command:

sudo hdparm -B /dev/sda
share|improve this answer
Yes, I forgot completely about hdparm. :) Thank you. HDD is not dying just can't park for some reason. That works like charm when netbook is on AC power. :D – MeanEYE Feb 9 '11 at 14:57

This is a pretty strange issue. My feeling is that it is related to power management or disk optimization being done by Ubuntu, even though you have disabled disk spin-down. How to resolve this problem is a bit of a mystery to me. I'd try looking for alternative drivers for your hard disk, and then using a different file system to see if that changes disk behavior. I'm pretty much stumped, though.

share|improve this answer
I don't think it has anything to do with file system, though I could be wrong. Clicking noise is still present but it doesn't seem to affect neither hard disk nor system. – MeanEYE Dec 26 '10 at 4:04
It may sound stupid but with other operating system you get the same problem (other distros livecd, windows minipe and similar stuff)? – Pitto Feb 9 '11 at 10:07
Hm, Windows was alive on that machine for 5 minutes, and then it was removed. But like I said, all the noise goes away once I plug in AC power. So it's not hard drive dying. And yes, hdparm solved it. – MeanEYE Feb 10 '11 at 10:05

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.