Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm running Ubuntu 10.10, and when I try to run the Update Manager, it keeps failing when attempting to install the updated hplip package. If I run it from the command-line, it shows a Python syntax error and fails after that.

The syntax looks correct in the error returned, so I'm not sure why it fails.

share|improve this question
add comment

1 Answer 1

up vote 1 down vote accepted

They switched to Python3 in Maverick, but the hplip configuration scripts rely on Python2. Change /usr/bin/python to point to /usr/bin/python2.6 instead of python3.1.

I hope my searching helps someone else :)

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.