Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have the message command not recognized though I checked in control that it was installed as explained here:

http://www.question-defense.com/2010/07/23/windows-7-telnet-is-not-recognized-as-an-internal-or-external-command

Is there something else like registry settings?

share|improve this question
    
can you see if it is installed by finding if telnet.exe is available under c:\windows subdirectory? Then try to execute it giving full path. And post the results. –  jhamu Nov 12 '10 at 11:59

3 Answers 3

I had this problem and it turned out I had the windows support tools installed. These were using a 64 bit command shell, and it wouldn't run the 32 bit binary of telnet (I am guessing.) Check the properties of your shortcut. If it is in the sysWOW64 folder, you are using the wrong command shell. You need the one in the system32 folder.

share|improve this answer

Try to uninstall it (go back to the control panel as explained in the link you posted, uncheck it and apply the change) then re-install it.
*make sure you mark Telnet Client, and not Telnet Server.

share|improve this answer

Finally I had to go to the System32 directory to be able to execute it. Why System32 is not in the path, I don't know.

share|improve this answer
    
You can add it back in Environment Variables if its missing. –  Ben Lavender Mar 29 '13 at 16:34

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.