Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a computer setup with a localhost in IIS, and the computer is visible on an internal network. In Windows XP IIS6, I could just type http://<computername>/ and I would see that user's localhost. In windows 7 IIS7 it seems this is disabled by default. How do I enable it?

share|improve this question

3 Answers 3

I believe you want to use the Control Panel Applet for Windows Firewall.

enter image description here

enter image description here

Then click on "inbound rules" and scroll to find the "World Wide Web Services (HTTP Traffic-in)" rule.

enter image description here

Enable it.

done.

share|improve this answer

It sounds like you developed this using WebMatrix. That installs IIS 7 Express, instead of IIS 7. It happened to me too, and I solved the problem by following the steps here: http://blog.alirobertson.com/post/11139712138/enabling-non-localhost-access-to-webmatrix

share|improve this answer

I had the same problem and resolved it by doing the following: Enter: Control Panel\System and Security\Windows Firewall

Click on: Allow a program or feature through Windows Firewall

Please make sure to enable: World Wide Web Services (HTTP) for Home/Work (Private)

I can now run my localhost webs in Win7 IIS from another PC within the same local network. Please note that trying to ping the remote PC will not respond unless you open windows firewall and turn off firewall on Home or work (private) network local settings (not recommended)

Regards Lars

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.