Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a LinkSys BEFSR41v4 router, is there a way to reboot (without doing a factory reset) this remotely from within the LAN it's connected to?

The reason I ask is that there isn't an option I can find to do this. Sometimes after using it for a few days it starts to misbehave (I suspect to do with Bit Torrent connections) and I need to reboot. I also plan to hide this unit in the attic which is miles away from where I work in the house.

Having Googled around I can't see any suggestions other than to power the unit from an X10 or similar device and power cycle it remotely that way.

I'm running firmware version 1.04.02.

share|improve this question
    
How remote? From within your home or over the Internet? The reason I ask is there might only be 1 option with that old of a router. –  ricbax Nov 12 '10 at 23:40
    
@ricbax - oh sorry, just within the LAN at home. –  Kev Nov 13 '10 at 0:19

6 Answers 6

Yes it can. Look in the firmware file, not in the web interface.

Use the curl command to reboot it read, Reboot Linksys remotely.

To use cURL in Windows read up on, URL to reboot a WebSTAR DPC2100R2 cable modem with curl?

share|improve this answer
    
Um no it can't :) There isn't a page with a reboot button on this router at all, I'd be happy to logon to it and push such a button and that would be fine. But sadly the firmware on the BEFSR41 isn't endowed with such a feature. You have to physically power cycle it. But thanks all the same. –  Kev Jan 25 '11 at 22:29
    
This may not work for the specific router mentioned in this question, but it is exactly the information I was looking for. Thank you. –  Keith Jan 18 '13 at 21:15

I seem to recall that the Linksys BEFSR41 had a tab labeled something like Administration and under there was something like Status. There used to be a soft reboot option there. Note that if you router is flaking out, you may not be able to get to the web interface. What do you mean when you say the router is misbehaving?

share|improve this answer
    
It sometimes stops routing, but I've never had a problem accessing the web interface. All I can see on the Administration -> Factory Defaults tab is "Restore Factory Defaults: Yes or No" –  Kev Nov 13 '10 at 0:52
up vote 1 down vote accepted

After a considerable amount of research it would appear that it's not possible to warm boot this router from the web based admin tools.

The router also isn't compatible with any of the WRT projects.

share|improve this answer

Log into the router's web admin pages and submit the settings without making any changes. The router will flash the red Diag light and that usually works for me.

share|improve this answer
    
Sadly not this one. –  Kev Aug 12 '11 at 22:14

Read step 7 of this:

The soft reset process for the Linksys router can be done via the Web Administration Pages. This requires the use of the Web browser of the computer. In the address bar of the Web browser, type the IP address of the Linksys router. If the user has not modified the IP address, the default is 192.168.1.1.

share|improve this answer
    
Hmm...that does a factory reset. Not what I'm after. –  Kev Nov 13 '10 at 0:30
    
Step 7 only does a soft reset, ignore everything else. Unless you don't know how to log into the router web interface. –  InBetween Nov 13 '10 at 0:32
    
@adam - step 9 says "Click on the 'Administration' tab and select the 'Factory Defaults' option. Click on the 'Yes' button beside the Restore Factory Defaults text.". As I read that it suggests it will do a factory reset –  Kev Nov 13 '10 at 0:46
    
Fixed my post. If you only look at step 7, under the Web Administration Page there should be a soft reset button, which is what you're looking for. I know when I had my linksys the soft reset button was around there, I don't know exactly where and I have since put DDWRT on the router instead. I hope this helps :) –  InBetween Nov 13 '10 at 0:52
    
Also, on that note, I have found DDWRT to be much more stable which is why I switched to it. You could go that rout if you want. - dd-wrt.com/site/index –  InBetween Nov 13 '10 at 0:56

This works on my Linksys BEFSR41 v3:

http://'':PASSWORD@192.168.1.1/Gozila.cgi?submit_button=Status_Router&submit_type=release&change_action=gozila_cgi&wan_proto=dhcp

Where it says PASSWORD, you'd put your router's password in.

Since we're using UserName:Password in the URL, and the BEFSR41's UserName is blank, you just leave the '' in there. Not sure what to call them... single quotes? ' '.

It'll automatically release the IP address and grab a new one, then redirect you to the Status_Router.htm page of the router, showing you the new IP address.

For some reason, the above doesn't work in Internet Explorer... but it works fine in Chrome and its derivatives.

So you'd create a URL shortcut on your Desktop thusly:

"C:\Program Files (x86)\SRWare Iron\iron.exe" --app=http://'':PASSWORD@192.168.1.1/Gozila.cgi?submit_button=Status_Router&submit_type=release&change_action=gozila_cgi&wan_proto=dhcp --incognito

I'm using SRWare Iron instead of Chrome. SRWare Iron strips out the Google-provided corporate spyware code. I've set it up as an app, so I can include the URL to the router, and I've used Incognito mode to prevent the browser from saving the URL (which has the router password in it).

Strange looking URL, but it actually works!

In regards to the OPs question... I believe you're right... the BEFSR41 has a limited amount of memory, and using BitTorrent on it with too many connections will cause it to act flakey (dropped connections, severely limited upload speed). It exhausts the SPI memory area, so it's forced to drop some connections.

So limiting your BitTorrent client to less than 20 connections, and refreshing your WAN IP address from time to time (which drops all connections and thus flushes the SPI memory) should keep it running good.

share|improve this answer
    
If you want to revise your answer or add information to it, edit it. Please also take the time to properly format your answer and use proper punctuation. –  Oliver Salzburg Mar 10 at 10:43
    
I up-voted you for your effort and good answer, nice job and thank you. –  user51047 Nov 23 at 2:29

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.