Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a problem with my video card. Whenever I run a DirectX 10 game, it works for a few seconds (10 or so) and then starts displaying nothing but big polygons.

I have tested this with Crysis and Resident Evil 5, both have the same problems. The same games running under DirectX 9 work fine, except for some small black squares once in a while.

I have the following specs:

Asus P7P55D LE
Intel Core i5 750
Sapphire Radeon HD4850 1GB
2x2GB Patriot Viper II Sector 5, DDR3 1600 MHz
OCZ Stealth X Stream 500SXS 500W

At first I thought it could be the video card overheating (it has stock cooling), but the game crashes even when it's running at 50 degrees C, and it's never been higher than 70.

I also thought it could be the PSU, but as far as I know 500W is enough for this computer, especially because I haven't overclocked anything.

My OS is Windows 7 X64 and I am using Catalyst 10.10, but I have also tried many older versions with no success.

I don't think there is a problem with the card itself, or else it wouldn't run DirectX 9 games I believe.

I have spent many hours searching for a solution but I couldn't, so any help is appreciated.

Thank you.

EDIT:

I did some further investigation about the problem, and it seems taspeotis was right, it might be related to memory.

I slightly underclocked the memory from 993 to 965 MHz and the problem went away completely. Both the black squares using DirectX 9 and the weird polygons using DirectX 10.

I was using RE DirectX 10 Benchmark, as it consistently crashed around the same point, and now I can play the full benchmark with no artifacts at all.

Unfortunately, the underclock has an obvious hit in performance. Although it's not critical, it's definitely noticeable.

So, if the video memory test software showed no erros, but the card needs an underclock to work, what might be the problem? Temperature? Voltage?

By the way, I couldn't find what the default voltage for this card is. And what is a good software to try and increase it? I tried Ati Tray Tools but it has a bug that increases the clock speed dramatically whenever I change something in the Overclock tab, so I'm afraid it might fry my card.

Worst case scenario, if I don't find I solution I will try to slightly increase the GPU clock to compensate for the memory clock.

Thank you again.

share|improve this question
    
Is the card new? You should get an RMA and return it to the distributor. –  RJFalconer Nov 12 '10 at 23:31
    
Have you tried uninstalling and reinstalling the drivers? Does this happen in many other games, or can you use some ATi demos to test the DX10 functionality? –  ssube Nov 13 '10 at 19:32
    
Unfortunately it's not a new card. I've had it for more than a year, but only recently I noticed this problem. I also tried reinstalling drivers but the problem continued. Strangely, I tried an ATI demo called Froblins and there were 0 artifacts, even though it is a graphics intensive DirectX 10 demo. –  ricsmania Nov 15 '10 at 12:45
    
Try taking it out and cleaning the fans and heatsink. If there is a cowling on it, try removing it if possible to really get it clean (put it back on after). I know you said it wasn't heat, but the temp measurement /probably/ doesn't measure memory temps. I had a card that had a piece of lint smaller than a pencil eraser stuck in the heatsink which would crash the card. –  horatio Jan 6 '11 at 15:58
add comment

3 Answers

What you describe points to dud video RAM. DirectX 10 and DirectX 9 will use the same memory but for different things, so you probably get lucky that DirectX 9 only exhibits black squares every so often and DirectX 10 uses it for vertex data.

I've have this problem with my ATI Radeon 9600, and my ATI Radeon Xpress 200M. ATI have an uncanny ability to churn out bad cards.

As best as I can tell, the memory can't be read and the card ends up using zeroes. So instead of polygons appearing at (x1, y1, z1) - (x2, y2, z2) - (x3, y3, z3) you end up with (x1, y1, z1) - (x2, y2, z2) - (0, 0, 0).

For your DirectX 9 problem the RGBA value 0 corresponds to black.

I have spent many hours searching for a solution but I couldn't, so any help is appreciated.

Buy nVidia.

share|improve this answer
2  
While your diagnosis may be correct, ATi doesn't even make the cards. Sapphire and VisionTek are excellent manufacturers, regularly making above-spec cards. It's more likely a random defect, and suggesting "nVidia" as the solution is simply inane. –  ssube Nov 13 '10 at 2:16
    
Hi, this seems to make sense, however I have tested the video card memory with a software called VMT (Video Memory Test), and after more than 1 hour testing the result came back with 0 errors. So if there is a problem with the card, it's probably not memory. And I won't spend money on another card until I'm sure this isn't a software problem. And I also don't think buying nVidia is a solution. Thanks! –  ricsmania Nov 13 '10 at 17:59
add comment

i think you must update your drivers now because amd solve many critical performance issues in the 11.1 release. and now you can download 11.3. catalyst 11.1 was the major release and i see a clear performance boost on my hd 5770. So try it and it can solve your problem. And 70 degree is just fine for your card because my card's fan only change speed when the card hit 65 degree mark.

and 500w is more then sufficient for your computer. so the only thing i can suggest is updating the drivers for your card.

share|improve this answer
add comment
  1. Uninstall the graphics driver through devmgmt.msc
  2. Reboot
  3. Install the latest WHQL driver (should be 13.1)
  4. Reboot
  5. Install the latest DirectX from Microsoft
  6. Reboot
  7. Install the latest .NET-Framework, the latest C++ runtime, the latest updates for your games and all other system updates
  8. Reboot
  9. Test

If this doesn't work, get a new Nvidia-Card.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.