Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am using Fedora 8 and Oracle 10g Express Edition.

Every time I start my fedora I have to click on start database.

How can I add startdb.sh to startup so that it automatically executes when Fedora starts?

I have tried adding the path to /etc/rc.d/rc.local but it still doesn't work.

./usr/lib/oracle/xe/app/oracle/product/10.2.0/server/config/scripts/startdb.sh

I have even tried to add this script in /etc/init.d/oracle

#!/bin/bash
#
# Run-level Startup script for the Oracle Instance and Listener
#
# chkconfig: 345 91 19
# description: Startup/Shutdown Oracle listener and instance

ORA_HOME="/u01/app/oracle/product/9.2.0.1.0"
ORA_OWNR="oracle"

# if the executables do not exist -- display error

if [ ! -f $ORA_HOME/bin/dbstart -o ! -d $ORA_HOME ]
then
        echo "Oracle startup: cannot start"
        exit 1
fi

# depending on parameter -- startup, shutdown, restart 
# of the instance and listener or usage display 

case "$1" in
    start)
        # Oracle listener and instance startup
        echo -n "Starting Oracle: "
        su - $ORA_OWNR -c "$ORA_HOME/bin/lsnrctl start"
        su - $ORA_OWNR -c $ORA_HOME/bin/dbstart
        touch /var/lock/subsys/oracle
        echo "OK"
        ;;
    stop)
    # Oracle listener and instance shutdown
        echo -n "Shutdown Oracle: "
        su - $ORA_OWNR -c "$ORA_HOME/bin/lsnrctl stop"
        su - $ORA_OWNR -c $ORA_HOME/bin/dbshut
        rm -f /var/lock/subsys/oracle
        echo "OK"
        ;;
    reload|restart)
        $0 stop
        $0 start
        ;;
    *)
        echo "Usage: $0 start|stop|restart|reload"
        exit 1
esac
exit 0

and even this doesn't work.

startdb.sh is located at /usr/lib/oracle/xe/app/oracle/product/10.2.0/server/config/scripts/startdb.sh

Thanks.

share|improve this question
    
@BillThor, harrymc I'll try it tomorrow in my college and let you know. Thanks for the answers. – Searock Nov 17 '10 at 6:32

Chect the execute permission on /etc/init.d/oracle. Test it by running /etc/init.d/oracle start, It should try to start oracle for you.

Check /etc/oratab has an entry for for your database flagged Y in the autostart column.

Check that you have the rc.d links using ls /etc/rc?.d/*oracle. There should be several entries for K19oracle and S91oracle. If not run chkconfig /etc/init.d/oracle and recheck.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .