Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm trying to install libapache2-mod-passenger (from backports) to a Debian Lenny system containing apache2-mpm-itk. What happens is this:

# aptitude install libapache2-mod-passenger
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Reading extended state information      
Initializing package states... Done
Reading task descriptions... Done  
The following packages are BROKEN:
  libapache2-mod-php5 
The following NEW packages will be installed:
  apache2-mpm-worker{a} javascript-common{a} libapache2-mod-passenger 
  libjs-prototype{a} librack-ruby{a} librack-ruby1.8{a} wwwconfig-common{a} 
The following packages will be REMOVED:
  apache2-mpm-itk{a} 
0 packages upgraded, 7 newly installed, 1 to remove and 0 not upgraded.
Need to get 792kB of archives. After unpacking 3191kB will be used.
The following packages have unmet dependencies:
  libapache2-mod-php5: Depends: apache2-mpm-prefork (> 2.0.52) but it is not installable or
                                apache2-mpm-itk but it is not installable
The following actions will resolve these dependencies:

Remove the following packages:
libapache2-mod-php5

Score is 119

Accept this solution? [Y/n/q/?]

As far as I understand, this is because mod_passenger requires Apache version >=2.2.9-9, but the apache2-mpm-itk of Lenny is only version 2.2.6-02. This is at least a reported bug, and even claims to be fixed, but apparently has been reported again. Is there any trick to get mod_passenger installed while keeping the mpm-itk flavor of Apache? Apparently Passenger would work with Apache 2.2.6-02, the problem is just that the package dependency is set to wrong version.

share|improve this question

If you just want to change the package dependencies apt-get source package-name
cd debian
nano control and change version requirements
cd ..
apt-get build-dep package-name
apt-get install build-essential devscripts fakeroot
debuild

for more on rolling your own debs here's a tutorial: http://ubuntuforums.org/showthread.php?t=51003

disregard the setting up directories as that's done by apt-get source

share|improve this answer
    
for all ruby/rails stuff i use lucid LTS and gem for the installs – RobotHumans Nov 13 '10 at 17:12
    
Thanks; I have no previous experience of de(re?)building Debian packages. Is it really as simple as those couple of commands? Does it make a .deb file, which I then install with dpkg? – Joonas Pulakka Nov 13 '10 at 17:15
    
it can be that simple...sometimes it isn't. added a couple lines since your box hasn't been used for this before...and yes it produces debs...you are re-building a package but you are deb-building hence debuild. – RobotHumans Nov 13 '10 at 17:45

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .