Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am running windows 7 on my host which has the microphone working just fine but I cannot get the mic to work under any guest (I have tried Ubuntu 10.4 and Windows XP). I am beginning to think that VirtualBox does not support the microphone.

share|improve this question

According to this VirtualBox ticket, this problem was fixed under version 3.1.4 of VirtualBox. Are you using 3.1.4 or later?

share|improve this answer
According to this [VirtualBox ticket] ( it is again not fixed. – hynekcer Oct 8 '12 at 8:24

This could be because of some problem with alsa configuration. Try checking out the current alsa configuration. alsactl store -f /tmp/foo

open /tmp/foo and check the values for Mux capture volume. If there is no entry for Mux capture volume, vbox is not able to virtualize the mic device. Turn off the vm image and in the settings-->audio section, try changing the Audio controller to some other device, if any.

start the vm again and store the config again alsactl store -f /tmp/bar

open and look for Mux capture volume, if its there, modify the value.0 and value.1 to some higher value (but within the range of DbMin and DbMax). save the file and restore the config using: alsactl restore -f /tmp/bar

This should work for you.

If there is no option for 'Mux capture volume`, I think that u won't be able to record using microphone from ur vm :(

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .