Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Possible Duplicate:
How to reset shortcuts (.lnk file) in Windows 7?
How do you associate the .exe file extension with a program in Windows?
Accidentally caused all .exe programs to open in Notepad

My friend e-mailed me a .lnk file, and I chose to open it with Wordpad. I think the check box for 'always open using this program' was checked, because all of my links now are opened using word pad. Is there a way to undo this?

share|improve this question

marked as duplicate by Renan, ChrisF, Hennes, Synetech, 8088 Oct 15 '12 at 2:21

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

    
What version of windows? –  MaQleod Nov 14 '10 at 7:45
    
Windows Vista 64-bit –  Amir Afghani Nov 14 '10 at 7:49

2 Answers 2

up vote 4 down vote accepted

There are two ways, but only one tends to work:

Go to Start -> Default Programs (on the right or just type it in). Click on Associate a file type or protocol with a program. Scroll down to .lnk and change the program.

If that doesn't work, then take a look here: http://support.microsoft.com/kb/172053

share|improve this answer

Yes. If you have Vista or Windows 7, press Start and type in regedit. Or, go to the registry editor in any other way.

Open the subfolders for HKEY_CURRENT_USER

  • software
  • Microsoft
  • Windows
  • Current Version
  • Explorer
  • fileExts
  • .lnk

Here, delete userchoice and then reboot.

share|improve this answer
    
Instead of userchoice you may see an OpenWithList key in which there is A Wordpad and possibly B <another setting> and MRU <another setting> Just delete all of these, the changes take effect immediately and fix the fault. –  user165214 Oct 14 '12 at 12:54

Not the answer you're looking for? Browse other questions tagged or ask your own question.