Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am creating a table of Figures based on image captions I have created.

However every time I create the captions some of them are missing in the table even after updating the table.

The specific version of Word I was using was 2007 (12.0.6545.5000) SP2 MSO (12.0.6535.5002) However I have upgraded to 2010, 14.0.4760.1000, only to suffer the same problems. I have tried making sure that the images were inserted into blocks of "Normal" format text and re-inserted and update the tables, but nothing seems to change the fact that some of the captions will remain missing.

Note that if I add two captions for a picture, the second will usually display, but not the first.

share|improve this question
up vote 10 down vote accepted

After a bit of research in finding this problem myself, I believe it is caused by having tracked changes on when trying to update the table of figures. Word gets confused with the various review copies around, and simply misses some entries. This can easily be fixed by accepting all changes (Review-> Accept -> Accept all changes in the document), and then updating again.

share|improve this answer

My problem was exactly defined by a known defect in Word. I had screenshots with a figure caption that I marked as "in line" for text wrapping. This is a problem as Word hides the caption inside a text box. The solution was to remove the "in line" setting and put the formatting in a simple table with no borders.

This posting can explain it better than I can:

The draw layer: a metaphysical space (and how to bring it back down to earth)

Also follow the reference link in that post if you want more technical detail of the problem. I don't recommend the "frame" alternative solution as the frame feature is buried in Word forms (I never found it on Mac version of MS Word).

share|improve this answer

protected by Community May 21 '13 at 12:15

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.