Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm getting this error when trying to do an install and build (Ubuntu 10.10):

 checking for DEPENDENCIES... configure: error: Package requirements (
     gtk+-2.0 >= 2.10.0
      pygtk-2.0
      x11
  ) were not met:

  No package 'pygtk-2.0' found

  Consider adjusting the PKG_CONFIG_PATH environment variable if you
  installed software in a non-standard prefix.

  Alternatively, you may set the environment variables DEPENDENCIES_CFLAGS
  and DEPENDENCIES_LIBS to avoid the need to call pkg-config.
  See the pkg-config man page for more details.

I've tried pointing PKG_CONFIG_PATH both to pkg-config and to the directory that holds all of the .pc files (/usr/share/pkg-config). The man page for pkg-config doesn't mention DEPENDENCIES_CFLAGS or DEPENDENCIES_LIBS. I'm at a bit of a loss. I've tried using aptitude to install everything I could find which involved the letters "gtk" to no avail.

Any suggestions? I would really prefer to use aptitude, apt-get or dpkg to solve this if at all possible. I haven't tried rebuilding those packages from source.

share|improve this question
    
What're you trying to build ? –  Sathya Nov 15 '10 at 16:04
    
I've been having difficulties with my Guake install, so I was hoping to install from source so that I could (possibly) debug it. –  cwallenpoole Nov 15 '10 at 18:43

2 Answers 2

up vote 2 down vote accepted

I suspect you want

apt-get build-dep guake

This installs all the packages you need to compile guake. Then you can do

apt-get source guake
cd guake-*/
# edit, patch, ...
dpkg-buildpackage -rfakeroot -us -uc -b -nc
share|improve this answer
    
That worked like a champ. I will up-vote this when I get the reputation. –  cwallenpoole Nov 15 '10 at 21:03

What is the output of this command?

dpkg --get-selections | grep pygtk

How about the same for x11?

It looks sort of as if you're trying to install a package that wants x11 when you have xorg installed, but I haven't tested that.

share|improve this answer
    
I don't understand your answer. There's no direct relationship between Debian/Ubuntu package names and pkg-config names. And xorg is the implementation of x11 on Ubuntu and just about everywhere. –  Gilles Nov 15 '10 at 20:48
    
dpkg --get-selections | grep gtk says I have python-gtk2 which is, as best as I can tell, the most current descendant. But, apt-get build-dep guake worked. Thanks. –  cwallenpoole Nov 15 '10 at 21:05

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.