Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm attempting to install Windows Server 2008 R2 on a development machine but the Installer refuses to see the hard drive. I'm booting off of a USB thumb drive and the installer loads fine but after selecting the OS version it says "No Drives were found. Click Load Driver to provide a mass storage driver for installation."

The motherboard is an MSI 785GM-P45 with an AMD 785G Northbridge and SB710 Southbridge. The hard drive is a Western Digital WD10EARS 1TB SATA with Advanced Format. The hard drive is detected in the BIOS and I've verified that it works by booting off of it with another OS installed.

I've tried the driver package from MSI as well as directly from AMD. I've even tried download individual drivers from here. The installer will detect certified drivers but after loading them it fails to detect the hard drive.

I've gone into the BIOS and set the SATA controller to AHCI, RAID and IDE modes and attempted to load the correct drivers to no avail.

I'd read somewhere that this can occur if your installation media is corrupt so I downloaded the ISO from Microsoft and rebuilt the thumb drive but still get the same error.

I'm kind of at a loss as to how to proceed. Has anyone ever encountered this problem before?

share|improve this question

2 Answers 2

up vote 3 down vote accepted

This Microsoft Support article contains many suggestions for solving the problem:

You cannot select or format a hard disk partition when you try to install Windows Vista, Windows 7 or Windows Server 2008 R2

share|improve this answer
    
Using the DISKPART utility I was able to clean the disk. Apparently the Windows Installer will not touch broken volumes which the disk contained. I guess this is a safety feature so that if you're trying to perform a recovery you don't actually delete the partitions you're trying to recover. Thanks! –  MyItchyChin Nov 16 '10 at 9:16
    
I'm having the same issue. What exactly did you do with diskpart? –  cc0 Mar 16 '12 at 10:47

What about the drivers from WD?

Also, since it's using Advanced Format you should also try using Acronis True Image and see if that works. It comes with the WD HDD, or you can download it for free since it's a WD HDD.

Report back on if that works...I'm curious.

share|improve this answer
    
There are no drivers for this drive from WD, there is a utility to configure the drive for OSes that don't support 4k sectors but 2k8r2 supports them. I don't have a spare hard drive laying around to try and install the OS on, I actually pulled this from a RAID array on another server I have as part of a transition from the older hardware. –  MyItchyChin Nov 15 '10 at 15:47
1  
Can you verify the disk works in another computer (not part of a RAID array)? It also shouldn't make a difference, but using another computer repartition the drive to where it's not part of a RAID array. I don't think it'll fix it, but it may be worth a shot if you have a spare computer around. –  Theo Nov 15 '10 at 16:08
    
It did make a difference! The installer would not touch a disk that had a broken volume on it. –  MyItchyChin Nov 16 '10 at 9:14

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.