Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a 18 month old Dell laptop that has always treated me well. Last night, as I was in the middle of typing a gmail to someone, I got a BSOD. I don't have the exact message in front of me but it was a Stop 0x7 of some sort, followed by a very quick memory dump and a restart.

This is what I get every time I reboot now. The windows progress bar will come up and do its thing, then go away and just before the login prompt normally appears the BSOD shows up. There's no helpful message associated with it, about a particular SYS driver or anything, just hex values and the Stop 0x7 message.

I haven't installed any new drivers in a long time, and the last program I installed was a MySQL GUI workbench about two days ago. I'm using Ad-Aware and AVG Antivirus and I keep them up to date. I also have WinPatrol watching for mischief.

The BSOD occurs in every startup mode except Safe Mode or Safe Mode with command prompt. Safe Mode with networking doesn't work (BSOD as usual), nor does any other startup mode involving boot logging or kernel debugging.

Safe mode works fine, except I have no networking and can't submit the crash info to Microsoft's automated crash resolution sytem-- not that I expect that to act as a silver bullet.

I can provide boot log text info here, once I copy the logs to a USB drive, but I was wondering what I might try in the meantime to find out what happened and how to fix it? Thanks for your help.

share|improve this question

3 Answers 3

first impression, based on your question, suggests an issue with the networking. have you tried removing and/or disabling all network adapters in safe mode and booting normally with them uninstalled/disabled?

share|improve this answer
1  
Just beat me to it. –  Joe Taylor Nov 15 '10 at 16:20
    
I'll give that a try, thanks. –  larryq Nov 15 '10 at 16:25

This is how I would approach this situation:

  1. Use NirSoft Bluescreen View to see what is going on with each blue screen and search online to see what the problems associated with it are.

  2. Test the memory using MemTest86+

  3. Try to boot to a linux distro. If it boots correctly then there's a possibility that something somewhere in the windows files are corrupt and therefore a system repair may be helpful (will probably have to use the install disk that came with the PC)

  4. As @Xantec suggested I would also look at the network card/drivers and see if there is an issue with them.

share|improve this answer
up vote 1 down vote accepted

Thanks for your help. I swapped out the memory and the same thing still happened, and NirSoft didn't provide any grand illumination on the problem (not its fault, it's a good piece of software, but the diagnostic info supplied in the dump files were of little use). I also disabled all networking hardware in the device manager, but nothing changed. Also disabled various services but again, nothing different came about.

In the end I did a repair install of Vista and things are working fine now.

With that in mind, is there a log kept somewhere of the repair procedure, so I could see if Vista discovered anything unusual during the pre-repair diagnostic it ran? Bit of a black box as to what it did to fix things.

share|improve this answer
1  
I think you had a corrupt driver. The repair install wiped those and replaced them with generic drivers included with Vista. –  AttackingHobo Nov 17 '10 at 22:39

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.